aboutsummaryrefslogtreecommitdiff
path: root/mail/sma/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/sma/Makefile')
-rw-r--r--mail/sma/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/sma/Makefile b/mail/sma/Makefile
new file mode 100644
index 000000000000..56ea4a423aef
--- /dev/null
+++ b/mail/sma/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: sma
+# Date created: 28. Mar 2002
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sma
+PORTVERSION= 1.0
+CATEGORIES= mail
+MASTER_SITES= http://www.klake.org/sma/dl/
+
+MAINTAINER= dinoex@FreeBSD.org
+
+MAN8= sma.8
+DOCSFILES= BUGS COPYRIGHT HISTORY README TODO
+SAMPLEFILES= sma.conf
+ALL_TARGET= sma
+
+do-configure:
+ ${PERL} -pi -e "s,CC =,CC?=," ${WRKSRC}/Makefile
+ ${PERL} -pi -e "s,CFLAGS = -Wall -O,CFLAGS+= ," \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sma ${PREFIX}/bin/sma
+ ${INSTALL_MAN} ${WRKSRC}/sma.8 ${PREFIX}/man/man8/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in ${DOCSFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.for i in ${SAMPLEFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>