aboutsummaryrefslogtreecommitdiff
path: root/mail/smc-milter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/smc-milter/Makefile')
-rw-r--r--mail/smc-milter/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/mail/smc-milter/Makefile b/mail/smc-milter/Makefile
new file mode 100644
index 000000000000..be5cffc3b1cd
--- /dev/null
+++ b/mail/smc-milter/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: smc-milter
+# Date created: 30 March 2005
+# Whom: Andrey E. Shevtsov
+#
+# $FreeBSD$
+#
+
+PORTNAME= smc-milter
+PORTVERSION= 1.5
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= milter
+
+MAINTAINER= nyxo@dnuc.polyn.kiae.su
+COMMENT= A non-context email filter
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libbind_r.a:${PORTSDIR}/dns/bind84
+LIB_DEPENDS= db-4.2.2:${PORTSDIR}/databases/db42
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+NOMAN=
+
+post-extract:
+ @${REINPLACE_CMD} -e 's|\/opt\/SMC|\/usr\/local\/etc\/smc|g ; \
+ s|aliases|mail\/aliases|g' \
+ ${WRKSRC}/smc-milter.h
+
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/smc-milter.sh \
+ ${PREFIX}/etc/rc.d/smc-milter.sh
+
+.include <bsd.port.mk>