aboutsummaryrefslogtreecommitdiff
path: root/mail/spamass-milter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/spamass-milter/Makefile')
-rw-r--r--mail/spamass-milter/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/mail/spamass-milter/Makefile b/mail/spamass-milter/Makefile
index f8352e671bbb..1fffd3f1088b 100644
--- a/mail/spamass-milter/Makefile
+++ b/mail/spamass-milter/Makefile
@@ -25,7 +25,8 @@ MAKE_JOBS_SAFE= yes
OPTIONS= ADDAUTH_PATCH "Bypass checks for SMTP AUTH connections" off \
REJECTTEXT_PATCH "Customize SMTP reject message" off \
LDAP "LDAP support" off \
- SENDMAIL_PORT "Build against sendmail port" off
+ SENDMAIL_PORT "Build against sendmail port" off \
+ IPV6 "Apply IPv6 whitelist patch" off
.include <bsd.port.pre.mk>
@@ -42,6 +43,10 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-rejecttext1
NEW_ARGS:= ${NEW_ARGS}R:
.endif
+.if defined(WITH_IPV6)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ipv6
+.endif
+
# extra-patch-options is modified in pre-patch
.if ${ORIG_ARGS} != ${NEW_ARGS}
EXTRA_PATCHES+= ${WRKDIR}/extra-patch-options