aboutsummaryrefslogtreecommitdiff
path: root/mail/spamprobe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/spamprobe/Makefile')
-rw-r--r--mail/spamprobe/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/mail/spamprobe/Makefile b/mail/spamprobe/Makefile
index f4e5d313d292..805479769860 100644
--- a/mail/spamprobe/Makefile
+++ b/mail/spamprobe/Makefile
@@ -6,29 +6,34 @@
#
PORTNAME= spamprobe
-PORTVERSION= 1.2a
+PORTVERSION= 1.4
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sw@gegenunendlich.de
COMMENT= Spam detector using Bayesian analysis of word counts
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
+USE_GCC= 3.2+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-default-8bit --enable-cdb
+CPPFLAGS= -I${LOCALBASE}/include/db4
+LDFLAGS= -L${LOCALBASE}/lib -ldb4
MAN1= spamprobe.1
PLIST_FILES= bin/spamprobe
-USE_OPENSSL= yes
-CPPFLAGS= -I${LOCALBASE}/include/db4 -I${OPENSSLINC}
-LDFLAGS= -L${LOCALBASE}/lib -ldb4 -lcrypto
+OPTIONS= UNGIF "Enable tokenization of GIF attachments with libungif" off
-post-install:
- @${CAT} ${PKGMESSAGE}
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if defined(WITH_UNGIF)
+LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+CPPFLAGS+= -I${LOCALBASE}/include
+.endif
+
+.include <bsd.port.post.mk>