aboutsummaryrefslogtreecommitdiff
path: root/mail/spamstats
diff options
context:
space:
mode:
Diffstat (limited to 'mail/spamstats')
-rw-r--r--mail/spamstats/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/mail/spamstats/Makefile b/mail/spamstats/Makefile
index 49138c39d2ad..8619e8cda9eb 100644
--- a/mail/spamstats/Makefile
+++ b/mail/spamstats/Makefile
@@ -21,22 +21,18 @@ PLIST_FILES= bin/spamstats.pl
USES= shebangfix perl5
SHEBANG_FILES= ${PORTNAME}${PORTVERSION}.pl
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -i '' -e 's|mail.log|maillog|g' \
${WRKSRC}/${PORTNAME}${PORTVERSION}.pl
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}${PORTVERSION}.pl ${PREFIX}/bin/${PORTNAME}.pl
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}${PORTVERSION}.pl \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}.pl
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>