aboutsummaryrefslogtreecommitdiff
path: root/mail/squirrelmail-timeout_user-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/squirrelmail-timeout_user-plugin/Makefile')
-rw-r--r--mail/squirrelmail-timeout_user-plugin/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/mail/squirrelmail-timeout_user-plugin/Makefile b/mail/squirrelmail-timeout_user-plugin/Makefile
index f3e476366ed4..5d80fb3a247f 100644
--- a/mail/squirrelmail-timeout_user-plugin/Makefile
+++ b/mail/squirrelmail-timeout_user-plugin/Makefile
@@ -5,12 +5,14 @@
# $FreeBSD$
#
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTNAME= timeout_user
PORTVERSION= 1.1.1
PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-0.5
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}-${PORTVERSION}-0.5
DIST_SUBDIR= squirrelmail
MAINTAINER= thomas@goodking.ca
@@ -19,7 +21,7 @@ COMMENT= Automatically logs a user out if they're idle for a set amount of time
RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
-SQUIRREL_PLUGIN_NAME= timeout_user
+SQUIRREL_PLUGIN_NAME= ${PORTNAME}
.ifdef SQUIRRELDIR
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
@@ -35,6 +37,7 @@ PLIST_SUB+= SQUIRRELDIR=squirrelmail
SUB_LIST+= "SQUIRRELDIR=squirrelmail"
.endif
.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -42,6 +45,8 @@ USE_PERL5_BUILD= yes
USE_PHP= yes
WANT_PHP_WEB= yes
+.include <bsd.port.pre.mk>
+
pre-everything::
@${ECHO} ""
.ifndef WITHOUT_ACTIVATE
@@ -71,4 +76,4 @@ post-install:
.endif
@${ECHO} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>