aboutsummaryrefslogtreecommitdiff
path: root/mail/sqwebmail
diff options
context:
space:
mode:
Diffstat (limited to 'mail/sqwebmail')
-rw-r--r--mail/sqwebmail/Makefile14
-rw-r--r--mail/sqwebmail/files/patch-sqwebmail::newmsg_create.c11
2 files changed, 24 insertions, 1 deletions
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 1c0930ccee07..243e65f3ee70 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sqwebmail
PORTVERSION= 4.0.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= courier
@@ -54,6 +54,10 @@ IMAGEURL?= ${WEBDATASUBDIR}
# set WITH_MAXMSGSIZE to max size of messages (including attachments)
# set WITH_MAXARGSIZE to max size of a text message (excluding attachments)
# set WITH_MAXFORMARGSIZE to max size of attachments
+#
+# set WITH_CHARSET=chset,chset,... to enable charsets.
+# Set it to "all" will enable all unicode charset mappings.
+# For available charsets just type "iconv -l"
CACHEDIR?= /var/sqwebmail/cache
CACHEOWNER?= bin
@@ -184,6 +188,14 @@ CONFIGURE_ARGS+= --with-maxargsize=${WITH_MAXARGSIZE}
CONFIGURE_ARGS+= --with-maxformargsize=${WITH_MAXFORMARGSIZE}
.endif
+.if defined(WITH_CHARSET)
+.if ${WITH_CHARSET:U} == ALL
+CONFIGURE_ARGS+= --enable-unicode
+.else
+CONFIGURE_ARGS+= --enable-unicode=${WITH_CHARSET}
+.endif
+.endif
+
MAN1= maildirmake.1
MAN7= authlib.7
MAN8= deliverquota.8 makeuserdb.8 userdb.8 userdbpw.8
diff --git a/mail/sqwebmail/files/patch-sqwebmail::newmsg_create.c b/mail/sqwebmail/files/patch-sqwebmail::newmsg_create.c
new file mode 100644
index 000000000000..dd077c618a27
--- /dev/null
+++ b/mail/sqwebmail/files/patch-sqwebmail::newmsg_create.c
@@ -0,0 +1,11 @@
+--- sqwebmail/newmsg_create.c.orig Mon Mar 29 21:07:15 2004
++++ sqwebmail/newmsg_create.c Mon Mar 29 21:07:41 2004
+@@ -628,7 +628,7 @@
+ {
+ struct lookup_buffers *lookup_buffer_list=0;
+ int rc;
+-char *s=strdup(value);
++char *s=rfc2047_decode_simple(value);
+
+ if (!s) enomem();
+ rc=lookup_addressbook_do(header, s, &lookup_buffer_list);