aboutsummaryrefslogtreecommitdiff
path: root/mail/sylpheed3
diff options
context:
space:
mode:
Diffstat (limited to 'mail/sylpheed3')
-rw-r--r--mail/sylpheed3/Makefile133
-rw-r--r--mail/sylpheed3/distinfo3
-rw-r--r--mail/sylpheed3/files/patch-libsylph-defs.h22
-rw-r--r--mail/sylpheed3/pkg-descr12
-rw-r--r--mail/sylpheed3/pkg-plist115
5 files changed, 0 insertions, 285 deletions
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
deleted file mode 100644
index 60c34e83297f..000000000000
--- a/mail/sylpheed3/Makefile
+++ /dev/null
@@ -1,133 +0,0 @@
-# New ports collection makefile for: sylpheed
-# Date created: 15 June 2000
-# Whom: shigeri <shigeri@m10.alpha-net.ne.jp>
-#
-# $FreeBSD$
-#
-
-PORTNAME= sylpheed
-PORTVERSION= 2.2.0
-CATEGORIES= mail ipv6
-MASTER_SITES= http://sylpheed.good-day.net/sylpheed/v${PORTVERSION:C/\.[^\.]*$//}/
-
-MAINTAINER= oliver@FreeBSD.org
-COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
-
-RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
-
-USE_BZIP2= yes
-USE_GETTEXT= yes
-USE_GMAKE= yes
-USE_ICONV= yes
-USE_X_PREFIX= yes
-USE_GNOME= gtk20
-GNU_CONFIGURE= yes
-USE_REINPLACE= yes
-
-# Sylpheed needs pthread if GnomeVFS is installed (GtkFileChooser uses it)
-CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --enable-ipv6 \
- --prefix=${PREFIX} \
- --with-libintl-prefix=${LOCALBASE} \
- --program-transform-name=''
-
-CONFLICTS= sylpheed-1.[0-8]* sylpheed-gtk2-[0-9]*
-
-OPTIONS= GPGME "Enable GnuPG support using GPGME." off \
- COMPFACE "Enable X-Face support." off \
- JPILOT "Enable JPilot support." off \
- LDAP "Enable LDAP support." off \
- SSL "Enable OpenSSL support." on \
- GTKSPELL "Enable Spell checking support" on
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_SSL)
-# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-CONFIGURE_ARGS+=--enable-ssl
-.else
-CONFIGURE_ARGS+=--disable-ssl
-.endif
-
-.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.15:${PORTSDIR}/security/gpgme
-RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
-CONFIGURE_ARGS+=--enable-gpgme
-.else
-CONFIGURE_ARGS+=--disable-gpgme
-.endif
-
-.if defined(WITH_COMPFACE)
-LIB_DEPENDS+= compface.1:${PORTSDIR}/mail/faces
-CONFIGURE_ARGS+=--enable-compface
-.else
-CONFIGURE_ARGS+=--disable-compface
-.endif
-
-.if defined(WITH_JPILOT)
-LIB_DEPENDS+= pisock.8:${PORTSDIR}/palm/pilot-link
-RUN_DEPENDS+= jpilot:${PORTSDIR}/palm/jpilot
-CONFIGURE_ARGS+=--enable-jpilot
-.else
-CONFIGURE_ARGS+=--disable-jpilot
-.endif
-
-.if defined(WITH_LDAP)
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--enable-ldap
-.else
-CONFIGURE_ARGS+=--disable-ldap
-.endif
-
-.if defined(WITH_GTKSPELL)
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
-CONFIGURE_ARGS+=--enable-gtkspell
-.else
-CONFIGURE_ARGS+=--disable-gtkspell
-.endif
-
-.if defined(WITH_GNOME)
-PLIST_FILES= share/gnome/applications/sylpheed.desktop \
- share/gnome/pixmaps/sylpheed.png
-.endif
-
-MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
- faq/en/Makefile.in faq/es/Makefile.in faq/fr/Makefile.in \
- faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
- manual/ja/Makefile.in src/Makefile.in libsylph/Makefile.in \
- src/icons/Makefile.in
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g; ' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}&|g' \
- ${WRKSRC}/libsylph/procmime.c
-
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's|^SUBDIRS = ac libsylph src po manual faq$$|SUBDIRS = ac libsylph src po|g' \
- ${WRKSRC}/Makefile.in
-.else
-.for i in ${MAKEFILES}
- @${REINPLACE_CMD} -e 's|^faqdir = @faqdir@$$|faqdir = ${DOCSDIR}/faq|g; \
- s|^manualdir = @manualdir@$$|manualdir = ${DOCSDIR}/manual|g' \
- ${WRKSRC}/${i}
-.endfor
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in ChangeLog INSTALL README TODO
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/${i}.ja ${DOCSDIR}
-.endfor
-.endif
-.if defined(WITH_GNOME)
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${PREFIX}/share/gnome/pixmaps/
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${PREFIX}/share/gnome/applications/
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/mail/sylpheed3/distinfo b/mail/sylpheed3/distinfo
deleted file mode 100644
index 2b6787e9e8ef..000000000000
--- a/mail/sylpheed3/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (sylpheed-2.2.0.tar.bz2) = da23e5c6ef869c4fe847ea9207f40ddf
-SHA256 (sylpheed-2.2.0.tar.bz2) = 72724821199dd92d9bb0068fc88054fc0144144889af7dc6dfea9ea4ae607a6c
-SIZE (sylpheed-2.2.0.tar.bz2) = 2492789
diff --git a/mail/sylpheed3/files/patch-libsylph-defs.h b/mail/sylpheed3/files/patch-libsylph-defs.h
deleted file mode 100644
index 7881004694d3..000000000000
--- a/mail/sylpheed3/files/patch-libsylph-defs.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- libsylph/defs.h.orig Tue Sep 13 16:55:49 2005
-+++ libsylph/defs.h Mon Sep 19 03:23:15 2005
-@@ -81,8 +81,8 @@
- #else
- # define DEFAULT_SIGNATURE ".signature"
- #endif
--#define DEFAULT_INC_PATH "/usr/bin/mh/inc"
--#define DEFAULT_INC_PROGRAM "inc"
-+#define DEFAULT_INC_PATH ""
-+#define DEFAULT_INC_PROGRAM ""
- /* #define DEFAULT_INC_PATH "/usr/bin/imget" */
- /* #define DEFAULT_INC_PROGRAM "imget" */
- #define DEFAULT_SENDMAIL_CMD "/usr/sbin/sendmail -t -i"
-@@ -91,7 +91,7 @@
- #ifdef _PATH_MAILDIR
- # define DEFAULT_SPOOL_PATH _PATH_MAILDIR
- #else
--# define DEFAULT_SPOOL_PATH "/var/spool/mail"
-+# define DEFAULT_SPOOL_PATH "/var/mail"
- #endif
-
- #define BUFFSIZE 8192
diff --git a/mail/sylpheed3/pkg-descr b/mail/sylpheed3/pkg-descr
deleted file mode 100644
index 3107ae5ca582..000000000000
--- a/mail/sylpheed3/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Sylpheed is an e-mail client (and news reader) based on GTK+ 2, running on
-X Window System, and aiming for:
- * Quick response
- * Graceful, and sophisticated interface
- * Easy configuration, intuitive operation
- * Abundant features
-
-Currently, many features are supported including POP3, IMAP, NNTP,
-multiple accounts, threading, filtering, MIME attachments, APOP, SMTP
-AUTH, SSL, IPv6, GnuPG, internalization, and more.
-
-WWW: http://sylpheed.good-day.net/
diff --git a/mail/sylpheed3/pkg-plist b/mail/sylpheed3/pkg-plist
deleted file mode 100644
index e373d69521aa..000000000000
--- a/mail/sylpheed3/pkg-plist
+++ /dev/null
@@ -1,115 +0,0 @@
-bin/sylpheed
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.ja
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.ja
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.ja
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/TODO.ja
-share/locale/cs/LC_MESSAGES/sylpheed.mo
-share/locale/bg/LC_MESSAGES/sylpheed.mo
-share/locale/da/LC_MESSAGES/sylpheed.mo
-share/locale/de/LC_MESSAGES/sylpheed.mo
-share/locale/el/LC_MESSAGES/sylpheed.mo
-share/locale/es/LC_MESSAGES/sylpheed.mo
-share/locale/et/LC_MESSAGES/sylpheed.mo
-share/locale/fr/LC_MESSAGES/sylpheed.mo
-share/locale/gl/LC_MESSAGES/sylpheed.mo
-share/locale/hr/LC_MESSAGES/sylpheed.mo
-share/locale/hu/LC_MESSAGES/sylpheed.mo
-share/locale/it/LC_MESSAGES/sylpheed.mo
-share/locale/ja/LC_MESSAGES/sylpheed.mo
-share/locale/ko/LC_MESSAGES/sylpheed.mo
-share/locale/lt/LC_MESSAGES/sylpheed.mo
-share/locale/nl/LC_MESSAGES/sylpheed.mo
-share/locale/pl/LC_MESSAGES/sylpheed.mo
-share/locale/pt_BR/LC_MESSAGES/sylpheed.mo
-share/locale/ro/LC_MESSAGES/sylpheed.mo
-share/locale/ru/LC_MESSAGES/sylpheed.mo
-share/locale/sk/LC_MESSAGES/sylpheed.mo
-share/locale/sl/LC_MESSAGES/sylpheed.mo
-share/locale/sr/LC_MESSAGES/sylpheed.mo
-share/locale/sv/LC_MESSAGES/sylpheed.mo
-share/locale/tr/LC_MESSAGES/sylpheed.mo
-share/locale/uk/LC_MESSAGES/sylpheed.mo
-share/locale/vi/LC_MESSAGES/sylpheed.mo
-share/locale/zh_CN/LC_MESSAGES/sylpheed.mo
-share/locale/zh_TW/LC_MESSAGES/sylpheed.mo
-%%PORTDOCS%%%%DOCSDIR%%/faq/de/sylpheed-faq-1.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/de/sylpheed-faq-2.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/de/sylpheed-faq-3.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/de/sylpheed-faq.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq-1.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq-2.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq-3.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/es/sylpheed-faq-1.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/es/sylpheed-faq-2.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/es/sylpheed-faq-3.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/es/sylpheed-faq.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/fr/sylpheed-faq-1.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/fr/sylpheed-faq-2.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/fr/sylpheed-faq-3.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/fr/sylpheed-faq.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/it/sylpheed-faq-1.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/it/sylpheed-faq-2.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/it/sylpheed-faq-3.html
-%%PORTDOCS%%%%DOCSDIR%%/faq/it/sylpheed-faq.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-1.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-10.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-11.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-12.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-13.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-14.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-15.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-16.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-17.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-18.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-19.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-2.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-20.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-3.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-4.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-5.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-6.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-7.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-8.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-9.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-1.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-10.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-11.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-12.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-13.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-14.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-15.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-16.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-17.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-18.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-19.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-2.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-20.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-21.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-22.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-3.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-4.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-5.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-6.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-7.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-8.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-9.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed.sgml
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/ja
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/en
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq/it
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq/fr
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq/es
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq/en
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq/de
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry share/locale/lt/LC_MESSAGES
-@dirrmtry share/locale/lt