aboutsummaryrefslogtreecommitdiff
path: root/mail/t-prot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/t-prot/Makefile')
-rw-r--r--mail/t-prot/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/mail/t-prot/Makefile b/mail/t-prot/Makefile
index 5093ddf4c09b..486089e56bf5 100644
--- a/mail/t-prot/Makefile
+++ b/mail/t-prot/Makefile
@@ -11,25 +11,24 @@ MAINTAINER= torres.g.alex@gmail.com
COMMENT= TOFU Protection - Display Filter for RFC822 messages
RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
- p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext
+ p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext
-USES= perl5
+USES= perl5 shebangfix
NO_BUILD= yes
-MAN1= t-prot.1
-DOCS= ChangeLog README TODO
+PORTDOCS= ChangeLog README TODO
+PORTEXAMPLES= *
+PLIST_FILES= man/man1/t-prot.1.gz bin/t-prot
+SHEBANG_FILES= t-prot
+
+OPTIONS_DEFINE= EXAMPLES DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/t-prot ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/t-prot.1 ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/contrib/* ${EXAMPLESDIR}
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/t-prot ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/t-prot.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/* ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>