aboutsummaryrefslogtreecommitdiff
path: root/mail/t-prot
diff options
context:
space:
mode:
Diffstat (limited to 'mail/t-prot')
-rw-r--r--mail/t-prot/Makefile29
-rw-r--r--mail/t-prot/pkg-descr2
-rw-r--r--mail/t-prot/pkg-plist17
3 files changed, 15 insertions, 33 deletions
diff --git a/mail/t-prot/Makefile b/mail/t-prot/Makefile
index 5093ddf4c09b..486089e56bf5 100644
--- a/mail/t-prot/Makefile
+++ b/mail/t-prot/Makefile
@@ -11,25 +11,24 @@ MAINTAINER= torres.g.alex@gmail.com
COMMENT= TOFU Protection - Display Filter for RFC822 messages
RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
- p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext
+ p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext
-USES= perl5
+USES= perl5 shebangfix
NO_BUILD= yes
-MAN1= t-prot.1
-DOCS= ChangeLog README TODO
+PORTDOCS= ChangeLog README TODO
+PORTEXAMPLES= *
+PLIST_FILES= man/man1/t-prot.1.gz bin/t-prot
+SHEBANG_FILES= t-prot
+
+OPTIONS_DEFINE= EXAMPLES DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/t-prot ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/t-prot.1 ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/contrib/* ${EXAMPLESDIR}
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/t-prot ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/t-prot.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/* ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/mail/t-prot/pkg-descr b/mail/t-prot/pkg-descr
index 74499bcb1259..b809d91a0b86 100644
--- a/mail/t-prot/pkg-descr
+++ b/mail/t-prot/pkg-descr
@@ -11,4 +11,4 @@ support for Mutt), but it can also be used in MTA/MDA - e.g. for immediately
bouncing "improper" messages.
Author: Jochen Striepe <t-prot@tolot.escape.de>
-WWW: http://www.escape.de/~tolot/mutt/
+WWW: http://www.escape.de/~tolot/mutt/
diff --git a/mail/t-prot/pkg-plist b/mail/t-prot/pkg-plist
deleted file mode 100644
index 59c59fceb877..000000000000
--- a/mail/t-prot/pkg-plist
+++ /dev/null
@@ -1,17 +0,0 @@
-bin/t-prot
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.examples
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.patches
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/filter_innd.pl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailcap.t-prot
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/muttrc.t-prot
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/muttrc.t-prot.m1512
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nailrc.t-prot
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/t-prot-r1.238-gpg126.diff
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/t-prot-r1.311-mutt1512.diff
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/t-prot.sl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/t-prot.sl-slang2.diff
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%