aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/vpopmail-devel/Makefile')
-rw-r--r--mail/vpopmail-devel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index 0d96bead0cf7..b12f83631615 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
GNU_CONFIGURE= YES
USE_GMAKE= YES
+USE_REINPLACE= YES
VCFGDIR?= ${WRKDIR}/vcfg
VCFGFILES?= inc_deps lib_deps tcp.smtp
@@ -238,6 +239,11 @@ CONFIGURE_ARGS+= --enable-users-big-dir=n
CONFIGURE_ARGS+= --enable-make-seekable=n
.endif
+# autoconf and automake can remove our patches to the configure scripts.
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e 's,@(ACLOCAL|AUTO(MAKE|CONF|HEADER))@,/usr/bin/true,'
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it