aboutsummaryrefslogtreecommitdiff
path: root/mail/vpopmail-stable
diff options
context:
space:
mode:
Diffstat (limited to 'mail/vpopmail-stable')
-rw-r--r--mail/vpopmail-stable/Makefile96
-rw-r--r--mail/vpopmail-stable/distinfo1
-rw-r--r--mail/vpopmail-stable/pkg-comment1
-rw-r--r--mail/vpopmail-stable/pkg-descr21
-rw-r--r--mail/vpopmail-stable/pkg-install87
-rw-r--r--mail/vpopmail-stable/pkg-plist45
6 files changed, 0 insertions, 251 deletions
diff --git a/mail/vpopmail-stable/Makefile b/mail/vpopmail-stable/Makefile
deleted file mode 100644
index 67233aeb3ec6..000000000000
--- a/mail/vpopmail-stable/Makefile
+++ /dev/null
@@ -1,96 +0,0 @@
-# New ports collection makefile for: vpopmail
-# Date created: 21 Sep 2000
-# Whom: Neil Blakey-Milner
-#
-# $FreeBSD$
-#
-
-PORTNAME= vpopmail
-PORTVERSION= 4.9.4
-CATEGORIES= mail
-MASTER_SITES= http://www.inter7.com/vpopmail/
-
-MAINTAINER= nbm@FreeBSD.org
-
-BUILD_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
- ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
-RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
- ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
-
-GNU_CONFIGURE= YES
-USE_GMAKE= YES
-
-CONFIGURE_ARGS= --enable-qmail-dir=${QMAIL_DIR} \
- --enable-tcprules-bin=${LOCALBASE}/bin/tcprules \
- --enable-tcpserver-file=${PREFIX}/vpopmail/etc/tcp.smtp
-
-#
-# User-configurable variables
-#
-# Define these to change from the default behaviour
-#
-# WITH_PASSWD - allow authentication off /etc/passwd
-# WITH_APOP - allow apop authentication
-# WITHOUT_ROAMING - disallow roaming users
-#
-# Set these to the values you'd prefer
-#
-# HARDQUOTA - size of hard quota, or 'n' for no hard quota
-# RELAYCLEAR - time in minutes before clearing relay hole (requires roaming)
-# LOGLEVEL - n - no logging, y - log all,
-# e - log errors, p - log passwords in errors
-# APOPFILE - location of apop secrets file
-# QMAIL_DIR - location of qmail directory
-# PREFIX - installation area for vpopmail (see comment below)
-#
-
-HARDQUOTA?= 10000000
-RELAYCLEAR?= 30
-LOGLEVEL?= y
-APOPFILE?= /etc/apop-secrets
-
-.if exists(${LOCALBASE}/qmail/bin/qmail-send)
-QMAIL_DIR?= ${LOCALBASE}/qmail
-.else
-QMAIL_DIR?= /var/qmail
-.endif
-
-# Uncomment this, or set PREFIX to /home if you have an existing
-# vpopmail install with the vpopmail users' home directory set to
-# /home/vpopmail - package rules dictate we default to /usr/local/vpopmail
-#
-#PREFIX?= /home
-
-# End of user-configurable variables
-
-#
-# Some suggestions from Gabriel Ambuehl <gabriel_ambuehl@buz.ch>
-#
-
-CONFIGURE_ARGS+= --enable-hardquota=${HARDQUOTA} \
- --enable-logging=${LOGLEVEL}
-
-.if !defined(WITH_PASSWD)
-CONFIGURE_ARGS+= --enable-passwd=n
-.endif
-
-.if defined(WITH_APOP)
-CONFIGURE_ARGS+= --enable-apop=y \
- --enable-apop-file=${APOPFILE}
-.endif
-
-.if !defined(WITHOUT_ROAMING)
-CONFIGURE_ARGS+= --enable-roaming-users=y \
- --enable-relay-clear-minutes=${RELAYCLEAR}
-.endif
-
-#
-# This port doesn't honour PREFIX, it honours vpopmail's home directory.
-# Since we create vpopmail if it doesn't exist, we set it so that it
-# does honour PREFIX. -- nbm
-#
-
-pre-configure:
- @PKG_PREFIX=${PREFIX}/vpopmail ${PERL5} ${PKGINSTALL}
-
-.include <bsd.port.mk>
diff --git a/mail/vpopmail-stable/distinfo b/mail/vpopmail-stable/distinfo
deleted file mode 100644
index a122ec2e667d..000000000000
--- a/mail/vpopmail-stable/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (vpopmail-4.9.4.tar.gz) = 7bac93ecd0641eb8c991c081a4cfd08e
diff --git a/mail/vpopmail-stable/pkg-comment b/mail/vpopmail-stable/pkg-comment
deleted file mode 100644
index 3a0300b4b781..000000000000
--- a/mail/vpopmail-stable/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Easy virtual domain and authentication package for use with qmail
diff --git a/mail/vpopmail-stable/pkg-descr b/mail/vpopmail-stable/pkg-descr
deleted file mode 100644
index a98ec621541b..000000000000
--- a/mail/vpopmail-stable/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-vpopmail provides an easy way to manage virtual domains and virtual
-accounts on a qmail mail server.
-
-Features:
-
-. Automates all qmail file modifications into documented command line
- programs
-
-. Support for named and IP-based virtual domains
-
-. NFS safe
-
-. dynamic directory creation for scalability using fill-in balanced 3
- level tree
-
-. understands standard qmail .qmail directives
-
-. interacts well with qmailadmin for web-based administration, courier-imap
- for IMAP support, and sqwebmail for web-based mail.
-
-WWW: http://inter7.com/vpopmail/
diff --git a/mail/vpopmail-stable/pkg-install b/mail/vpopmail-stable/pkg-install
deleted file mode 100644
index f3004e7de913..000000000000
--- a/mail/vpopmail-stable/pkg-install
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/usr/bin/perl
-#
-
-@groups = ("vchkpw");
-%users = ('vpopmail', "vchkpw");
-# daemon, local, pop, queue, remote, deliver, respectively.
-# alias is a special case above...
-%gids = ("vchkpw", 89);
-%uids = ('vpopmail', 89);
-
-if ($ENV{PACKAGE_BUILDING} || $ARGV[1] eq "PRE-INSTALL") {
- $doguid=1; # Make sure we get the assigned guids.
-}
-
-foreach $group (@groups) {
- if (! getgrnam ($group)) {
- do checkrpw; # May exit
-
- $x = "-g $gids{$group}";
- $result = system ("/usr/sbin/pw groupadd $group $x");
- if ($result) {
- die "Failed to add group $group as gid $gids{$group}\n";
- }
- }
-}
-
-if (! getpwnam ("alias")) {
- do checkrpw; # May exit
-
- $x = "-u $uids{'alias'}";
- $result = system ("/usr/sbin/pw useradd alias -g qnofiles -d \"$ENV{PKG_PREFIX}/alias\" -s /nonexistent $x");
- if ($result) {
- die "Failed to add user alias as uid $uids{'alias'}\n";
- }
-}
-
-foreach $user (keys %users) {
- if (! getpwnam ($user)) {
- do checkrpw; # May exit
-
- $x = "-u $uids{$user}";
- $result = system ("/usr/sbin/pw useradd $user -g $users{$user} -d \"$ENV{PKG_PREFIX}\" -s /nonexistent $x");
- if ($result) {
- die "Failed to add user $user as uid $uids{$user}\n";
- }
- }
-}
-
-# Check that all gids/uids are as they should be...
-# If we are being installed as a package...
-if ($doguid) {
- foreach $group (@groups) {
- if (getgrnam($group) != $gids{$group}) {
- die "Group $group should have gid $gids{$group}\n";
- }
- }
-
- foreach $user (keys %users) {
- if (getpwnam($user) != $uids{$user}) {
- die "User $user should have uid $uids{$user}\n";
- }
- }
-}
-
-exit 0;
-
-sub checkrpw {
- if (! -x "/usr/sbin/pw") {
- print <<'EOM';
-This system looks like a pre-2.2 version of FreeBSD. We see that it
-is missing the "pw" utility. We need this utility. Please get and
-install it, and try again. You can get the source from:
-
- ftp://ftp.freebsd.org/pub/FreeBSD/FreeBSD-current/src/usr.sbin/pw.tar.gz
-
-EOM
- die "No /usr/sbin/pw";
- }
-
- if ($> != 0) {
- print "It is necessary to add missing vpopmail users/groups at";
- print "this stage. Please either add them manually or retry";
- print "as root.";
- # Let pw(1) signal the failure so the user can see which
- # group/user is actually missing.
- }
-}
diff --git a/mail/vpopmail-stable/pkg-plist b/mail/vpopmail-stable/pkg-plist
deleted file mode 100644
index a8c5eace203d..000000000000
--- a/mail/vpopmail-stable/pkg-plist
+++ /dev/null
@@ -1,45 +0,0 @@
-vpopmail/bin/clearopensmtp
-vpopmail/bin/vaddaliasdomain
-vpopmail/bin/vadddomain
-vpopmail/bin/vadduser
-vpopmail/bin/vchkpw
-vpopmail/bin/vconvert
-vpopmail/bin/vdeldomain
-vpopmail/bin/vdelivermail
-vpopmail/bin/vdeluser
-vpopmail/bin/vmkpasswd
-vpopmail/bin/vmoduser
-vpopmail/bin/vpasswd
-vpopmail/bin/vpopbull
-vpopmail/bin/vsetuserquota
-vpopmail/bin/vuserinfo
-vpopmail/doc/doc_html/vpopmail.html
-vpopmail/doc/doc_html/vpopmailapi.png
-vpopmail/doc/man_html/clearopensmtp.html
-vpopmail/doc/man_html/index.html
-vpopmail/doc/man_html/vaddaliasdomain.html
-vpopmail/doc/man_html/vadddomain.html
-vpopmail/doc/man_html/vadduser.html
-vpopmail/doc/man_html/vchkpw.html
-vpopmail/doc/man_html/vconvert.html
-vpopmail/doc/man_html/vdeldomain.html
-vpopmail/doc/man_html/vdelivermail.html
-vpopmail/doc/man_html/vdeluser.html
-vpopmail/doc/man_html/vpasswd.html
-vpopmail/doc/man_html/vpopbull.html
-vpopmail/doc/man_html/vsetuserquota.html
-vpopmail/include/config.h
-vpopmail/include/vauth.h
-vpopmail/include/vpopmail.h
-vpopmail/include/vpopmail_config.h
-vpopmail/lib/libvpopmail.a
-@dirrm vpopmail/users
-@dirrm vpopmail/lib
-@dirrm vpopmail/include
-@dirrm vpopmail/etc
-@dirrm vpopmail/domains
-@dirrm vpopmail/doc/man_html
-@dirrm vpopmail/doc/doc_html
-@dirrm vpopmail/doc
-@dirrm vpopmail/bin
-@dirrm vpopmail