aboutsummaryrefslogtreecommitdiff
path: root/mail/xfmail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/xfmail/Makefile')
-rw-r--r--mail/xfmail/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/mail/xfmail/Makefile b/mail/xfmail/Makefile
index aa2131ad3a1f..de4814642978 100644
--- a/mail/xfmail/Makefile
+++ b/mail/xfmail/Makefile
@@ -22,15 +22,26 @@ USE_AUTOMAKE= yes
USE_BZIP2= yes
USE_GLIB= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
USE_X_PREFIX= yes
USE_XPM= yes
+# XXX: Disable patching for libtool until we can generate the files
+LIBTOOLFILES=
+
.include <bsd.port.pre.mk>
CONFIGURE_ARGS= --with-dbm-lib=gdbm
+
+.if defined(WITH_ESOUND)
+USE_ESOUND= yes
+CONFIGURE_ARGS+= --with-esd-sound
+.endif
+
MAN1= xfmail.1
pre-configure:
- @cd ${WRKSRC} && ${SH} autogen.sh
+ @(cd ${WRKSRC} && ${SH} autogen.sh); \
+ ${MAKE} LIBTOOLFILES=aclocal.m4 patch-libtool
.include <bsd.port.post.mk>