aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile13
-rw-r--r--mail/mutt/Makefile13
-rw-r--r--mail/mutt14/Makefile13
3 files changed, 39 insertions, 0 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 41c1ec86f058..b59d8f585517 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -373,6 +373,14 @@ CONFIGURE_ARGS+= --enable-gpgme
.else
CONFIGURE_ARGS+= --disable-gpgme
.endif
+.if !defined(WITHOUT_GSSAPI)
+.if exists(${LOCALBASE}/bin/krb5-config)
+LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
+CONFIGURE_ARGS+= --with-gss=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-gss
+.endif
+.endif
PATCH_DIST_STRIP= -p1
@@ -441,6 +449,11 @@ post-patch::
pre-configure::
@(cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I m4)
+.if !exists(${LOCALBASE}/bin/krb5-config)
+ @${ECHO_CMD} "#define HAVE_HEIMDAL" >> ${WRKSRC}/config.h.in
+ @${REINPLACE_CMD} -e 's|<gssapi/gssapi\.h>|<gssapi.h>|' \
+ ${WRKSRC}/imap/auth_gss.c
+.endif
.if defined(MUTT_SLAVE_HTML_PAGES)
SCRIPTS_ENV+= MUTT_SLAVE_HTML_PAGES="${MUTT_SLAVE_HTML_PAGES}"
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index b937bd2563c7..b1a8eed76a34 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -118,6 +118,14 @@ CFLAGS+= -I${PREFIX}/include/ncurses -I${PREFIX}/include
.if defined(WITH_MUTT_CYRUS_SASL)
CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.endif
+.if !defined(WITHOUT_GSSAPI)
+.if exists(${LOCALBASE}/bin/krb5-config)
+LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
+CONFIGURE_ARGS+= --with-gss=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-gss
+.endif
+.endif
MAN1= mutt.1 mutt_dotlock.1
MAN5= mbox.5 muttrc.5
@@ -139,6 +147,11 @@ post-patch::
pre-configure::
@(cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I m4)
+.if !exists(${LOCALBASE}/bin/krb5-config)
+ @${ECHO_CMD} "#define HAVE_HEIMDAL" >> ${WRKSRC}/config.h.in
+ @${REINPLACE_CMD} -e 's|<gssapi/gssapi\.h>|<gssapi.h>|' \
+ ${WRKSRC}/imap/auth_gss.c
+.endif
# XXX
# this should be done automagically by aclocal but ....
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index b937bd2563c7..b1a8eed76a34 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -118,6 +118,14 @@ CFLAGS+= -I${PREFIX}/include/ncurses -I${PREFIX}/include
.if defined(WITH_MUTT_CYRUS_SASL)
CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.endif
+.if !defined(WITHOUT_GSSAPI)
+.if exists(${LOCALBASE}/bin/krb5-config)
+LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
+CONFIGURE_ARGS+= --with-gss=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-gss
+.endif
+.endif
MAN1= mutt.1 mutt_dotlock.1
MAN5= mbox.5 muttrc.5
@@ -139,6 +147,11 @@ post-patch::
pre-configure::
@(cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I m4)
+.if !exists(${LOCALBASE}/bin/krb5-config)
+ @${ECHO_CMD} "#define HAVE_HEIMDAL" >> ${WRKSRC}/config.h.in
+ @${REINPLACE_CMD} -e 's|<gssapi/gssapi\.h>|<gssapi.h>|' \
+ ${WRKSRC}/imap/auth_gss.c
+.endif
# XXX
# this should be done automagically by aclocal but ....