aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/sendmail/Makefile10
-rw-r--r--mail/sendmail811/Makefile10
-rw-r--r--mail/sendmail812/Makefile10
3 files changed, 21 insertions, 9 deletions
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index f19828ddc180..3add0aec1a24 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -33,7 +33,6 @@ MAN8= sendmail.8 mailstats.8 makemap.8 praliases.8 smrsh.8 \
SENDMAIL= ${PREFIX}/sbin/sendmail
BASEMAIL= /usr/libexec/sendmail/sendmail
PLIST_SUB+= PREFIX=${PREFIX:S=${PREFIX}/==}
-LDAP_PORT?= net/openldap21-client
PKGMESSAGE= ${WRKSRC}/pkg-message
# Options to define Features:
@@ -66,8 +65,13 @@ CONFLICTS+= sendmail+tls-8.* \
sendmail+sasl1-8.* \
sendmail+sasl2-8.*
CONFLICTS+= sendmail-sasl-8.* sendmail-sasl2-8.* sendmail-tls-8.*
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
-LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
+.if defined(LDAP_PORT)
+OPENLDAP_LIB?= libldap.so.2
+BUILD_DEPENDS+= ${LOCALBASE}/lib/${OPENLDAP_LIB}:${PORTSDIR}/${LDAP_PORT}
+RUN_DEPENDS+= ${LOCALBASE}/lib/${OPENLDAP_LIB}:${PORTSDIR}/${LDAP_PORT}
+.else
+USE_OPENLDAP_VER?= 21
+.endif
.else
CONFLICTS+= sendmail*+ldap*-8.*
.endif
diff --git a/mail/sendmail811/Makefile b/mail/sendmail811/Makefile
index 2a468319bb5d..03182c3860b7 100644
--- a/mail/sendmail811/Makefile
+++ b/mail/sendmail811/Makefile
@@ -31,7 +31,6 @@ MAN1= mailq.1 newaliases.1 vacation.1
MAN5= aliases.5
MAN8= sendmail.8 mailstats.8 makemap.8 praliases.8 smrsh.8 \
mail.local.8 rmail.8
-LDAP_PORT?= net/openldap21-client
# Options to define Features:
# SENDMAIL_WITHOUT_IPV6=yes
@@ -51,8 +50,13 @@ CONFLICTS+= sendmail+tls-8.* \
sendmail+sfio+sasl-8.* \
sendmail+sasl-8.*
CONFLICTS+= sendmail-sasl-8.* sendmail-tls-8.*
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
-LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
+.if defined(LDAP_PORT)
+OPENLDAP_LIB?= libldap.so.2
+BUILD_DEPENDS+= ${LOCALBASE}/lib/${OPENLDAP_LIB}:${PORTSDIR}/${LDAP_PORT}
+RUN_DEPENDS+= ${LOCALBASE}/lib/${OPENLDAP_LIB}:${PORTSDIR}/${LDAP_PORT}
+.else
+USE_OPENLDAP_VER?= 21
+.endif
.endif
.if defined(SENDMAIL_WITH_SASL)
SASL_SUFFIX?= +sasl
diff --git a/mail/sendmail812/Makefile b/mail/sendmail812/Makefile
index 3e7a5a013070..fd8e2206590e 100644
--- a/mail/sendmail812/Makefile
+++ b/mail/sendmail812/Makefile
@@ -39,7 +39,6 @@ MAN8= sendmail.8 mailstats.8 makemap.8 praliases.8 smrsh.8 \
SENDMAIL= ${PREFIX}/sbin/sendmail
BASEMAIL= /usr/libexec/sendmail/sendmail
PLIST_SUB+= PREFIX=${PREFIX:S=${PREFIX}/==}
-LDAP_PORT?= net/openldap21-client
PKGMESSAGE= ${WRKSRC}/pkg-message
# Options to define Features:
@@ -73,8 +72,13 @@ CONFLICTS+= sendmail+tls-8.* \
sendmail+sasl1-8.* \
sendmail+sasl2-8.*
CONFLICTS+= sendmail-sasl-8.* sendmail-sasl2-8.* sendmail-tls-8.*
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
-LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
+.if defined(LDAP_PORT)
+OPENLDAP_LIB?= libldap.so.2
+BUILD_DEPENDS+= ${LOCALBASE}/lib/${OPENLDAP_LIB}:${PORTSDIR}/${LDAP_PORT}
+RUN_DEPENDS+= ${LOCALBASE}/lib/${OPENLDAP_LIB}:${PORTSDIR}/${LDAP_PORT}
+.else
+USE_OPENLDAP_VER?= 21
+.endif
.else
CONFLICTS+= sendmail*+ldap*-8.*
.endif