aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/postfinger/Makefile39
-rw-r--r--mail/postfinger/distinfo4
-rw-r--r--mail/postfinger/pkg-descr4
4 files changed, 48 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index fc2d4791a98d..146ce9c06e59 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -287,6 +287,7 @@
SUBDIR += popper
SUBDIR += poppwd
SUBDIR += poppy
+ SUBDIR += postfinger
SUBDIR += postfix
SUBDIR += postfix-current
SUBDIR += postfix1
diff --git a/mail/postfinger/Makefile b/mail/postfinger/Makefile
new file mode 100644
index 000000000000..c514d397054c
--- /dev/null
+++ b/mail/postfinger/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: postfinger
+# Date created: 16 May 2003
+# Whom: Andrew J. Caines <A.J.Caines@halplant.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postfinger
+PORTVERSION= 1.29
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.nobandwidth.net/pub/postfix-mudd/postfinger/ \
+ ftp://ftp.wl0.org/postfinger/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+DISTFILES= ${PORTNAME}-${PORTVERSION} README
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= A.J.Caines@halplant.com
+COMMENT= Postfix Configuration Summary Reporter
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+
+PLIST_FILES= bin/postfinger
+
+PORTDOCS= README
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/postfinger/distinfo b/mail/postfinger/distinfo
new file mode 100644
index 000000000000..7127592e8977
--- /dev/null
+++ b/mail/postfinger/distinfo
@@ -0,0 +1,4 @@
+MD5 (postfinger/postfinger-1.29) = 12f2aa42b87b9863150620febdd596a3
+SIZE (postfinger/postfinger-1.29) = 8373
+MD5 (postfinger/README) = 8798a1359d1afc08c9ddb4e44a13e217
+SIZE (postfinger/README) = 760
diff --git a/mail/postfinger/pkg-descr b/mail/postfinger/pkg-descr
new file mode 100644
index 000000000000..04cf8a093041
--- /dev/null
+++ b/mail/postfinger/pkg-descr
@@ -0,0 +1,4 @@
+Postfix configuration summary and reporting tool by Simon J. Mudd
+Useful for seeking assistance on the postfix-user mailing list.
+
+FTP: ftp://ftp.wl0.org/SOURCES/postfinger