aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Email-FolderType/Makefile25
-rw-r--r--mail/p5-Email-FolderType/distinfo1
-rw-r--r--mail/p5-Email-FolderType/pkg-descr3
-rw-r--r--mail/p5-Email-FolderType/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ab791f7e4bb4..c9543b00f7e1 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -175,6 +175,7 @@
SUBDIR += offlineimap
SUBDIR += openwebmail
SUBDIR += p5-Email-Find
+ SUBDIR += p5-Email-FolderType
SUBDIR += p5-Email-Simple
SUBDIR += p5-Email-Valid
SUBDIR += p5-Email-Valid-Loose
diff --git a/mail/p5-Email-FolderType/Makefile b/mail/p5-Email-FolderType/Makefile
new file mode 100644
index 000000000000..9307c327619d
--- /dev/null
+++ b/mail/p5-Email-FolderType/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Email-FolderType
+# Date created: August 31 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-FolderType
+PORTVERSION= 0.6
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Determine the type of a mail folder
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::FolderType.3
+
+test:
+ cd ${WRKSRC} ; make test
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-FolderType/distinfo b/mail/p5-Email-FolderType/distinfo
new file mode 100644
index 000000000000..a79d68341d6e
--- /dev/null
+++ b/mail/p5-Email-FolderType/distinfo
@@ -0,0 +1 @@
+MD5 (Email-FolderType-0.6.tar.gz) = 54a74b1fd8f5bfedabc82808c1fa7502
diff --git a/mail/p5-Email-FolderType/pkg-descr b/mail/p5-Email-FolderType/pkg-descr
new file mode 100644
index 000000000000..e85473d0d565
--- /dev/null
+++ b/mail/p5-Email-FolderType/pkg-descr
@@ -0,0 +1,3 @@
+Provides a utility subroutine for detecting the type of a given mail folder.
+
+WWW: http://search.cpan.org/dist/Email-FolderType
diff --git a/mail/p5-Email-FolderType/pkg-plist b/mail/p5-Email-FolderType/pkg-plist
new file mode 100644
index 000000000000..b94a78413539
--- /dev/null
+++ b/mail/p5-Email-FolderType/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Email/FolderType.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/FolderType/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/FolderType
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email 2>/dev/null || true