aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/amavis-logwatch/Makefile3
-rw-r--r--mail/dkimproxy/Makefile2
-rw-r--r--mail/exipick/Makefile3
-rw-r--r--mail/getlive/Makefile3
-rw-r--r--mail/ovs/Makefile2
-rw-r--r--mail/p5-IMAP-Sieve/Makefile3
-rw-r--r--mail/p5-MIME-AltWords/Makefile3
-rw-r--r--mail/p5-MIME-Lite-HTML/Makefile3
-rw-r--r--mail/p5-Mail-CheckUser/Makefile3
-rw-r--r--mail/p5-Mail-Folder/Makefile3
-rw-r--r--mail/p5-Mail-SendEasy/Makefile3
-rw-r--r--mail/p5-Net-QMTP/Makefile3
-rw-r--r--mail/p5-Net-Server-Mail/Makefile3
-rw-r--r--mail/pflogstats/Makefile2
-rw-r--r--mail/squirrelmail-compatibility-plugin/Makefile3
-rw-r--r--mail/squirrelmail-spam-buttons-plugin/Makefile3
-rw-r--r--mail/squirrelmail-tmda-plugin/Makefile2
-rw-r--r--mail/squirrelmail-unsafe_image_rules-plugin/Makefile3
-rw-r--r--mail/t-prot/Makefile2
19 files changed, 33 insertions, 19 deletions
diff --git a/mail/amavis-logwatch/Makefile b/mail/amavis-logwatch/Makefile
index bc01bc25bf9f..70e11b8d7ccb 100644
--- a/mail/amavis-logwatch/Makefile
+++ b/mail/amavis-logwatch/Makefile
@@ -22,7 +22,8 @@ PORTEXAMPLES= ${PORTNAME}.conf
MAN1= ${PORTNAME}.1
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
post-patch:
diff --git a/mail/dkimproxy/Makefile b/mail/dkimproxy/Makefile
index 35beb4ca7f7e..59985c1811e0 100644
--- a/mail/dkimproxy/Makefile
+++ b/mail/dkimproxy/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= p5-Mail-DKIM>=0:${PORTSDIR}/mail/p5-Mail-DKIM \
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
USE_RC_SUBR= dkimproxy_in dkimproxy_out
DKIMPROXYUSER= dkimproxy
diff --git a/mail/exipick/Makefile b/mail/exipick/Makefile
index dfb7ee70d770..aa90a0f48fc3 100644
--- a/mail/exipick/Makefile
+++ b/mail/exipick/Makefile
@@ -17,7 +17,8 @@ COMMENT= Display messages from Exim queue based on a variety of criteria
PLIST_FILES= bin/${PORTNAME}
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
do-extract:
@${RM} -rf ${WRKDIR}
diff --git a/mail/getlive/Makefile b/mail/getlive/Makefile
index ae6d2189471b..760cc0891e46 100644
--- a/mail/getlive/Makefile
+++ b/mail/getlive/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
p5-URI>=0:${PORTSDIR}/net/p5-URI
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
PLIST_FILES= bin/getlive etc/getlive.conf.sample
PORTDOCS= ChangeLog License Manual
diff --git a/mail/ovs/Makefile b/mail/ovs/Makefile
index 5cb17328ce4c..a5fb1a4b10bb 100644
--- a/mail/ovs/Makefile
+++ b/mail/ovs/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= rrdtool>=0:${PORTSDIR}/databases/rrdtool \
p5-File-Tail>=0:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
CGIDIR?= ${PREFIX}/www/cgi-bin
DATADIR?= /var/db/ovs
diff --git a/mail/p5-IMAP-Sieve/Makefile b/mail/p5-IMAP-Sieve/Makefile
index 5e6885888c0a..0ddfa2e76b70 100644
--- a/mail/p5-IMAP-Sieve/Makefile
+++ b/mail/p5-IMAP-Sieve/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
WRKSRC= ${WRKDIR}/${PERLSIEVENAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
PERLSIEVENAME= perlsieve-${PORTVERSION}
PERLSIEVESUFX= b
diff --git a/mail/p5-MIME-AltWords/Makefile b/mail/p5-MIME-AltWords/Makefile
index 4ecde15f4dea..a9a34a93de9d 100644
--- a/mail/p5-MIME-AltWords/Makefile
+++ b/mail/p5-MIME-AltWords/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dliakh@ukr.net
COMMENT= Perl module for encoding and decoding MIME words
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MIME::AltWords.3 \
MIME::AltWords0.3
diff --git a/mail/p5-MIME-Lite-HTML/Makefile b/mail/p5-MIME-Lite-HTML/Makefile
index 10c6726b4cbf..3ff8b129aa2e 100644
--- a/mail/p5-MIME-Lite-HTML/Makefile
+++ b/mail/p5-MIME-Lite-HTML/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MIME::Lite::HTML.3
diff --git a/mail/p5-Mail-CheckUser/Makefile b/mail/p5-Mail-CheckUser/Makefile
index a1a7741df149..ca80c53706a5 100644
--- a/mail/p5-Mail-CheckUser/Makefile
+++ b/mail/p5-Mail-CheckUser/Makefile
@@ -18,7 +18,8 @@ COMMENT= Perl module to check email addresses for validity
BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= cufilter.1
MAN3= Mail::CheckUser.3
diff --git a/mail/p5-Mail-Folder/Makefile b/mail/p5-Mail-Folder/Makefile
index 7d49eb653cbe..94734b7bdd15 100644
--- a/mail/p5-Mail-Folder/Makefile
+++ b/mail/p5-Mail-Folder/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-Mail-Tools>=0:${PORTSDIR}/mail/p5-Mail-Tools \
p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Mail::Folder.3 Mail::Folder::Emaul.3 Mail::Folder::Mbox.3 \
Mail::Folder::NNTP.3 Mail::Folder::Maildir.3
diff --git a/mail/p5-Mail-SendEasy/Makefile b/mail/p5-Mail-SendEasy/Makefile
index 53c08dfc9ec7..45ddab3099da 100644
--- a/mail/p5-Mail-SendEasy/Makefile
+++ b/mail/p5-Mail-SendEasy/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Send plain/html e-mails through SMTP servers
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mail::SendEasy.3 Mail::SendEasy::AUTH.3 \
Mail::SendEasy::SMTP.3
diff --git a/mail/p5-Net-QMTP/Makefile b/mail/p5-Net-QMTP/Makefile
index 51bc5dcd3ba6..0456cdbd7a16 100644
--- a/mail/p5-Net-QMTP/Makefile
+++ b/mail/p5-Net-QMTP/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl module to provide a Quick Mail Transfer Protocol (QMTP) client
BUILD_DEPENDS= p5-Text-Netstring>=0:${PORTSDIR}/textproc/p5-Text-Netstring
RUN_DEPENDS= p5-Text-Netstring>=0:${PORTSDIR}/textproc/p5-Text-Netstring
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::QMTP.3
diff --git a/mail/p5-Net-Server-Mail/Makefile b/mail/p5-Net-Server-Mail/Makefile
index 2ce11d91695d..803dbcebda86 100644
--- a/mail/p5-Net-Server-Mail/Makefile
+++ b/mail/p5-Net-Server-Mail/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vvelox@vvelox.net
COMMENT= Implementation of SMTP, ESMTP, and LMTP protocols
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Server::Mail.3 \
Net::Server::Mail::ESMTP.3 \
diff --git a/mail/pflogstats/Makefile b/mail/pflogstats/Makefile
index fb1c7e96ed47..237289edc409 100644
--- a/mail/pflogstats/Makefile
+++ b/mail/pflogstats/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
p5-XML-Dumper>=0:${PORTSDIR}/textproc/p5-XML-Dumper
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
SITE_PERL_INST= ${SITE_PERL:S/${LOCALBASE}/${PREFIX}/}
post-patch:
diff --git a/mail/squirrelmail-compatibility-plugin/Makefile b/mail/squirrelmail-compatibility-plugin/Makefile
index 675778102b9a..cc60356afa7f 100644
--- a/mail/squirrelmail-compatibility-plugin/Makefile
+++ b/mail/squirrelmail-compatibility-plugin/Makefile
@@ -13,7 +13,8 @@ DIST_SUBDIR= squirrelmail
MAINTAINER= tabthorpe@FreeBSD.org
COMMENT= Required by many plugins for compatibility with SquirrelMail
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
CONFLICTS= squirrelmail-compatibility-plugin-1.*
diff --git a/mail/squirrelmail-spam-buttons-plugin/Makefile b/mail/squirrelmail-spam-buttons-plugin/Makefile
index 400f40878989..fed169dbe4cd 100644
--- a/mail/squirrelmail-spam-buttons-plugin/Makefile
+++ b/mail/squirrelmail-spam-buttons-plugin/Makefile
@@ -10,7 +10,8 @@ MAINTAINER= itetcu@FreeBSD.org
COMMENT= Provides buttons with customizable action (for reporting spam, etc.)
USE_SM_COMPAT= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
diff --git a/mail/squirrelmail-tmda-plugin/Makefile b/mail/squirrelmail-tmda-plugin/Makefile
index 222b9c1089f3..58e95188ef93 100644
--- a/mail/squirrelmail-tmda-plugin/Makefile
+++ b/mail/squirrelmail-tmda-plugin/Makefile
@@ -19,7 +19,7 @@ COMMENT= Adds TMDA support to SquirrelMail
RUN_DEPENDS= tmda-filter:${PORTSDIR}/mail/tmda \
${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
SQUIRREL_PLUGIN_NAME= tmdatools
diff --git a/mail/squirrelmail-unsafe_image_rules-plugin/Makefile b/mail/squirrelmail-unsafe_image_rules-plugin/Makefile
index 3ac62f970884..f5a95dd3e57d 100644
--- a/mail/squirrelmail-unsafe_image_rules-plugin/Makefile
+++ b/mail/squirrelmail-unsafe_image_rules-plugin/Makefile
@@ -11,7 +11,8 @@ MAINTAINER= itetcu@FreeBSD.org
COMMENT= Determines what unsafe (web) images will be shown
USE_SM_COMPAT= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
diff --git a/mail/t-prot/Makefile b/mail/t-prot/Makefile
index 0c276f1da65a..e7c612ad7036 100644
--- a/mail/t-prot/Makefile
+++ b/mail/t-prot/Makefile
@@ -17,7 +17,7 @@ COMMENT= TOFU Protection - Display Filter for RFC822 messages
RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
MAN1= t-prot.1