aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/sentinel/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index d3c81a1baaba..db7af24a7cc0 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -24,10 +24,8 @@ USE_REINPLACE= yes
.if !exists(/usr/lib/libmilter.a) && !exists(${LOCALBASE}/lib/libmilter.a)
IGNORE= requires Sendmail 8.12
.endif
-.if exists(${LOCALBASE}/lib/libmilter.a)
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.endif
post-patch:
@${REINPLACE_CMD} -e \
@@ -35,8 +33,8 @@ post-patch:
do-build:
cd ${WRKSRC} && \
- ${CC} ${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
- -o ${PORTNAME} ${PORTNAME}.c -L${LOCALBASE}/lib \
+ ${CC} ${CFLAGS} ${PTHREAD_CFLAGS} \
+ -o ${PORTNAME} ${PORTNAME}.c ${LDFLAGS} \
-lmilter -lpcre -lpcreposix ${PTHREAD_LIBS}
do-install: