aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix-current/Makefile2
-rw-r--r--mail/postfix-current/distinfo4
-rw-r--r--mail/postfix-current/pkg-plist2
-rw-r--r--mail/postfix-current/scripts/configure.postfix12
4 files changed, 14 insertions, 6 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 2bf8cb24f831..41c375722877 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -15,7 +15,7 @@
# NOTE: PCRE is enabled by default unless you specifically disable it.
PORTNAME= postfix
-PORTVERSION= 2.0.14-20030717
+PORTVERSION= 2.0.14-20030812
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index 619964df119f..4795d600fc81 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,2 +1,4 @@
-MD5 (postfix/postfix-2.0.14-20030717.tar.gz) = 82709b0742d886f345d718aa941b154d
+MD5 (postfix/postfix-2.0.14-20030812.tar.gz) = 7e78521f7c7241dd7c442924804ef10d
+MD5 (postfix/tls+ipv6-1.17-pf-2.0.14-20030812.patch.gz) = 671a9792c9296d644b006e16c1c31a6c
+MD5 (postfix/ipv6-1.17-pf-2.0.14-20030812.patch.gz) = 00ecc0be7dcbcc4dc8a5b5e4352b8036
MD5 (postfix/pfixtls-0.8.15a-2.0.14-20030715-0.9.7b.tar.gz) = b7572506f62cd5c64614128a5f0491e3
diff --git a/mail/postfix-current/pkg-plist b/mail/postfix-current/pkg-plist
index d1b095dfdff3..0402b3c43fe8 100644
--- a/mail/postfix-current/pkg-plist
+++ b/mail/postfix-current/pkg-plist
@@ -31,6 +31,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -104,6 +105,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix-current/scripts/configure.postfix b/mail/postfix-current/scripts/configure.postfix
index 7a12d2f3314a..a08bcb58450f 100644
--- a/mail/postfix-current/scripts/configure.postfix
+++ b/mail/postfix-current/scripts/configure.postfix
@@ -24,8 +24,8 @@ SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" "$status_SASL" \
SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" "$status_SASL2" \
SASLKRB "If your SASL requires Kerberos select this option" "$status_SASLKRB" \
TLS "SSL and TLS" "$status_TLS" \
-IPv6 "IPv6 support (broken)" "$status_IPv6" \
-IPv6TLS "IPv6 support with SSL and TLS (broken)" "$status_IPv6TLS" \
+IPv6 "IPv6 support" "$status_IPv6" \
+IPv6TLS "IPv6 support with SSL and TLS" "$status_IPv6TLS" \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" "$status_DB3" \
DB40 "Berkeley DB4.0 (required if SASL also built with DB4.0)" "$status_DB40" \
DB41 "Berkeley DB4.1 (required if SASL also built with DB4.1)" "$status_DB41" \
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -196,11 +197,12 @@ while [ "$1" ]; do
exit 1
fi
echo "PATCH_SITES+= http://www.ipnet6.org/postfix/download/"
- echo "PATCHFILES+= ipv6-1.15-pf-2.0.12-20030621.patch.gz"
+ echo "PATCHFILES+= ipv6-1.17-pf-2.0.14-20030812.patch.gz"
echo "PATCH_DIST_STRIP= -p1"
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -213,10 +215,11 @@ while [ "$1" ]; do
echo "POSTFIX_CCARGS+= -DHAS_SSL -I\${OPENSSLINC}"
echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
echo "PATCH_SITES+= http://www.ipnet6.org/postfix/download/"
- echo "PATCHFILES+= tls+ipv6-1.15-pf-2.0.12-20030621.patch.gz"
+ echo "PATCHFILES+= tls+ipv6-1.17-pf-2.0.14-20030812.patch.gz"
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -229,6 +232,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but