aboutsummaryrefslogtreecommitdiff
path: root/math/asir2000/files
diff options
context:
space:
mode:
Diffstat (limited to 'math/asir2000/files')
-rw-r--r--math/asir2000/files/patch-aa45
-rw-r--r--math/asir2000/files/patch-aa.orig45
-rw-r--r--math/asir2000/files/patch-ab11
-rw-r--r--math/asir2000/files/patch-ab.orig11
-rw-r--r--math/asir2000/files/patch-ac12
-rw-r--r--math/asir2000/files/patch-ac.orig14
-rw-r--r--math/asir2000/files/patch-ad48
-rw-r--r--math/asir2000/files/patch-ad.orig48
-rw-r--r--math/asir2000/files/patch-ae13
-rw-r--r--math/asir2000/files/patch-ae.orig13
-rw-r--r--math/asir2000/files/patch-ag26
-rw-r--r--math/asir2000/files/patch-ag.orig24
-rw-r--r--math/asir2000/files/patch-ba79
-rw-r--r--math/asir2000/files/patch-bb10
-rw-r--r--math/asir2000/files/patch-bc10
-rw-r--r--math/asir2000/files/patch-bd10
-rw-r--r--math/asir2000/files/patch-be10
-rw-r--r--math/asir2000/files/patch-bf10
-rw-r--r--math/asir2000/files/patch-bg11
-rw-r--r--math/asir2000/files/patch-bh10
-rw-r--r--math/asir2000/files/patch-bi11
-rw-r--r--math/asir2000/files/patch-bk10
22 files changed, 343 insertions, 138 deletions
diff --git a/math/asir2000/files/patch-aa b/math/asir2000/files/patch-aa
index 982bf286213a..e69de29bb2d1 100644
--- a/math/asir2000/files/patch-aa
+++ b/math/asir2000/files/patch-aa
@@ -1,45 +0,0 @@
---- include/Risa.tmpl.orig Sat Oct 6 01:24:22 2001
-+++ include/Risa.tmpl Tue Oct 23 02:44:17 2001
-@@ -11,7 +11,7 @@
- /* #define USE_FFT_FLOAT */
- /* #define USE_LAPACK */
- /* #define USE_FEP */
--/* #undef OpenXM_HOME */
-+#undef OpenXM_HOME
- /* #define USE_INTERVAL */
-
- #if defined(LinuxArchitecture)
-@@ -38,7 +38,7 @@
- #endif
-
- ASIR_BINDIR=$(ROOTDIR)/bin
--ASIR_LIBDIR=$(ROOTDIR)/lib/asir
-+ASIR_LIBDIR=$(ROOTDIR)/share/asir
- ASIR_INCDIR=$(ROOTDIR)/include/asir
- GC_INCDIR=$(ROOTDIR)/include/gc
-
-@@ -48,8 +48,6 @@
- CC= cc
- #endif
-
--CDEBUGFLAGS= -g -O
--
- #if defined(SunArchitecture)
- #if SystemV4
- #if defined(SparcArchitecture)
-@@ -114,7 +112,15 @@
-
- #ifdef USE_LAPACK
- LAPACK=1
-+#if defined(OpenXM_HOME)
- LAPACKLIB = -llapack -lblas -lI77 -lF77
-+#else
-+#ifdef FreeBSDArchitecture && OSMajorVersion >= 4
-+LAPACKLIB = -L/usr/local/lib -lg2c -llapack -lblas
-+#else
-+LAPACKLIB = -L/usr/local/lib -lf2c -llapack -lblas
-+#endif
-+#endif
- #else
- LAPACK=0
- LAPACKLIB =
diff --git a/math/asir2000/files/patch-aa.orig b/math/asir2000/files/patch-aa.orig
new file mode 100644
index 000000000000..982bf286213a
--- /dev/null
+++ b/math/asir2000/files/patch-aa.orig
@@ -0,0 +1,45 @@
+--- include/Risa.tmpl.orig Sat Oct 6 01:24:22 2001
++++ include/Risa.tmpl Tue Oct 23 02:44:17 2001
+@@ -11,7 +11,7 @@
+ /* #define USE_FFT_FLOAT */
+ /* #define USE_LAPACK */
+ /* #define USE_FEP */
+-/* #undef OpenXM_HOME */
++#undef OpenXM_HOME
+ /* #define USE_INTERVAL */
+
+ #if defined(LinuxArchitecture)
+@@ -38,7 +38,7 @@
+ #endif
+
+ ASIR_BINDIR=$(ROOTDIR)/bin
+-ASIR_LIBDIR=$(ROOTDIR)/lib/asir
++ASIR_LIBDIR=$(ROOTDIR)/share/asir
+ ASIR_INCDIR=$(ROOTDIR)/include/asir
+ GC_INCDIR=$(ROOTDIR)/include/gc
+
+@@ -48,8 +48,6 @@
+ CC= cc
+ #endif
+
+-CDEBUGFLAGS= -g -O
+-
+ #if defined(SunArchitecture)
+ #if SystemV4
+ #if defined(SparcArchitecture)
+@@ -114,7 +112,15 @@
+
+ #ifdef USE_LAPACK
+ LAPACK=1
++#if defined(OpenXM_HOME)
+ LAPACKLIB = -llapack -lblas -lI77 -lF77
++#else
++#ifdef FreeBSDArchitecture && OSMajorVersion >= 4
++LAPACKLIB = -L/usr/local/lib -lg2c -llapack -lblas
++#else
++LAPACKLIB = -L/usr/local/lib -lf2c -llapack -lblas
++#endif
++#endif
+ #else
+ LAPACK=0
+ LAPACKLIB =
diff --git a/math/asir2000/files/patch-ab b/math/asir2000/files/patch-ab
index 470ed606fa5f..e69de29bb2d1 100644
--- a/math/asir2000/files/patch-ab
+++ b/math/asir2000/files/patch-ab
@@ -1,11 +0,0 @@
---- Imakefile.org Sun Feb 4 20:11:38 2001
-+++ Imakefile Sun Feb 4 20:12:03 2001
-@@ -98,7 +98,7 @@
-
- install:: $(PROGRAMS)
- MakeDir($(ASIR_LIBDIR))
-- $(INSTALL) $(INSTALLFLAGS) $(PROGRAMS) $(ASIR_LIBDIR)
-+ $(INSTALL) $(INSTALLFLAGS) $(PROGRAMS) $(ASIR_BINDIR)
-
- install-bin-lib:: $(PROGRAMS)
- MakeDir($(ASIR_LIBDIR))
diff --git a/math/asir2000/files/patch-ab.orig b/math/asir2000/files/patch-ab.orig
new file mode 100644
index 000000000000..470ed606fa5f
--- /dev/null
+++ b/math/asir2000/files/patch-ab.orig
@@ -0,0 +1,11 @@
+--- Imakefile.org Sun Feb 4 20:11:38 2001
++++ Imakefile Sun Feb 4 20:12:03 2001
+@@ -98,7 +98,7 @@
+
+ install:: $(PROGRAMS)
+ MakeDir($(ASIR_LIBDIR))
+- $(INSTALL) $(INSTALLFLAGS) $(PROGRAMS) $(ASIR_LIBDIR)
++ $(INSTALL) $(INSTALLFLAGS) $(PROGRAMS) $(ASIR_BINDIR)
+
+ install-bin-lib:: $(PROGRAMS)
+ MakeDir($(ASIR_LIBDIR))
diff --git a/math/asir2000/files/patch-ac b/math/asir2000/files/patch-ac
index 5261f14b439d..7e3283113a9d 100644
--- a/math/asir2000/files/patch-ac
+++ b/math/asir2000/files/patch-ac
@@ -1,14 +1,10 @@
--- include/version.h.orig Tue Jan 28 17:38:58 2003
-+++ include/version.h Thu Feb 6 16:31:53 2003
-@@ -47,5 +47,9 @@
++++ include/version.h Sun Mar 2 21:15:34 2003
+@@ -47,5 +47,5 @@
*
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.90 2003/01/28 08:38:58 noro Exp $
*/
--#define ASIR_VERSION 20030128
+-#define ASIR_VERSION 20030507
-#define ASIR_DISTRIBUTION "Kobe"
-+#define ASIR_VERSION 20030215
++#define ASIR_VERSION 20030513
+#define ASIR_DISTRIBUTION "Plotting Group"
-+#define PARI_DEVEL_VERSION "PARI 2.2.4.alpha, copyright (C) 2000,
-+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier"
-+#define PARI_DEVEL_VERSION "PARI 2.2.4.alpha, copyright (C) 2000,
-+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier"
diff --git a/math/asir2000/files/patch-ac.orig b/math/asir2000/files/patch-ac.orig
new file mode 100644
index 000000000000..5261f14b439d
--- /dev/null
+++ b/math/asir2000/files/patch-ac.orig
@@ -0,0 +1,14 @@
+--- include/version.h.orig Tue Jan 28 17:38:58 2003
++++ include/version.h Thu Feb 6 16:31:53 2003
+@@ -47,5 +47,9 @@
+ *
+ * $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.90 2003/01/28 08:38:58 noro Exp $
+ */
+-#define ASIR_VERSION 20030128
+-#define ASIR_DISTRIBUTION "Kobe"
++#define ASIR_VERSION 20030215
++#define ASIR_DISTRIBUTION "Plotting Group"
++#define PARI_DEVEL_VERSION "PARI 2.2.4.alpha, copyright (C) 2000,
++ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier"
++#define PARI_DEVEL_VERSION "PARI 2.2.4.alpha, copyright (C) 2000,
++ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier"
diff --git a/math/asir2000/files/patch-ad b/math/asir2000/files/patch-ad
index bc546c3fe4f4..e69de29bb2d1 100644
--- a/math/asir2000/files/patch-ad
+++ b/math/asir2000/files/patch-ad
@@ -1,48 +0,0 @@
---- configure.orig Wed Jan 15 22:51:27 2003
-+++ configure Thu Jan 16 01:43:33 2003
-@@ -4,6 +4,7 @@
- use_plot=0
- use_pari=0
- use_interval=0
-+use_lapack=0
- use_fep=0
- oxhome=/usr/local
-
-@@ -24,6 +25,8 @@
- use_pari=2 ;;
- -interval)
- use_interval=1 ;;
-+ -lapack)
-+ use_lapack=1 ;;
- -fep)
- use_fep=1 ;;
- esac
-@@ -43,12 +46,16 @@
- libname=$libname"_pari"
- libpari=pari
- echo "#define USE_PARI" >> include/config.h
-+echo "#define PARI_VERSION \"PARI ${OLD_PARI_VERSION}, copyright (C) 2000,
-+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
- fi
-
- if [ $use_pari = 2 ]; then
- libname=$libname"_pari"
- libpari=pari-2.2
- echo "#define USE_PARI" >> include/config.h
-+echo "#define PARI_DEVEL_VERSION \"PARI ${PARI_VERSION}, copyright (C) 2000,
-+ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
- fi
-
- if [ $use_plot != 0 ]; then
-@@ -61,6 +68,11 @@
- echo "#define USE_INTERVAL" >> include/config.h
- fi
-
-+if [ $use_lapack != 0 ]; then
-+echo "#define USE_LAPACK" >> include/config.h
-+echo "#define LAPACK_VERSION \"LAPACK Project Version ${LAPACK_VERSION}\"" >> include/version.h
-+fi
-+
- if [ $use_fep != 0 ]; then
- echo "#define USE_FEP" >> include/config.h
- fi
diff --git a/math/asir2000/files/patch-ad.orig b/math/asir2000/files/patch-ad.orig
new file mode 100644
index 000000000000..bc546c3fe4f4
--- /dev/null
+++ b/math/asir2000/files/patch-ad.orig
@@ -0,0 +1,48 @@
+--- configure.orig Wed Jan 15 22:51:27 2003
++++ configure Thu Jan 16 01:43:33 2003
+@@ -4,6 +4,7 @@
+ use_plot=0
+ use_pari=0
+ use_interval=0
++use_lapack=0
+ use_fep=0
+ oxhome=/usr/local
+
+@@ -24,6 +25,8 @@
+ use_pari=2 ;;
+ -interval)
+ use_interval=1 ;;
++ -lapack)
++ use_lapack=1 ;;
+ -fep)
+ use_fep=1 ;;
+ esac
+@@ -43,12 +46,16 @@
+ libname=$libname"_pari"
+ libpari=pari
+ echo "#define USE_PARI" >> include/config.h
++echo "#define PARI_VERSION \"PARI ${OLD_PARI_VERSION}, copyright (C) 2000,
++ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
+ fi
+
+ if [ $use_pari = 2 ]; then
+ libname=$libname"_pari"
+ libpari=pari-2.2
+ echo "#define USE_PARI" >> include/config.h
++echo "#define PARI_DEVEL_VERSION \"PARI ${PARI_VERSION}, copyright (C) 2000,
++ C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier\"" >> include/version.h
+ fi
+
+ if [ $use_plot != 0 ]; then
+@@ -61,6 +68,11 @@
+ echo "#define USE_INTERVAL" >> include/config.h
+ fi
+
++if [ $use_lapack != 0 ]; then
++echo "#define USE_LAPACK" >> include/config.h
++echo "#define LAPACK_VERSION \"LAPACK Project Version ${LAPACK_VERSION}\"" >> include/version.h
++fi
++
+ if [ $use_fep != 0 ]; then
+ echo "#define USE_FEP" >> include/config.h
+ fi
diff --git a/math/asir2000/files/patch-ae b/math/asir2000/files/patch-ae
index 3c4e7f5a1b2d..e69de29bb2d1 100644
--- a/math/asir2000/files/patch-ae
+++ b/math/asir2000/files/patch-ae
@@ -1,13 +0,0 @@
---- builtin/numerical.c.org Thu Aug 16 18:47:06 2001
-+++ builtin/numerical.c Thu Aug 16 18:47:52 2001
-@@ -51,7 +51,11 @@
- #include "parse.h"
-
- #if LAPACK
-+#if (__FreeBSD__ >= 4)
-+#include <g2c.h>
-+#else
- #include <f2c.h>
-+#endif
-
- void Pflinsolve();
diff --git a/math/asir2000/files/patch-ae.orig b/math/asir2000/files/patch-ae.orig
new file mode 100644
index 000000000000..3c4e7f5a1b2d
--- /dev/null
+++ b/math/asir2000/files/patch-ae.orig
@@ -0,0 +1,13 @@
+--- builtin/numerical.c.org Thu Aug 16 18:47:06 2001
++++ builtin/numerical.c Thu Aug 16 18:47:52 2001
+@@ -51,7 +51,11 @@
+ #include "parse.h"
+
+ #if LAPACK
++#if (__FreeBSD__ >= 4)
++#include <g2c.h>
++#else
+ #include <f2c.h>
++#endif
+
+ void Pflinsolve();
diff --git a/math/asir2000/files/patch-ag b/math/asir2000/files/patch-ag
index 53825d645738..ccbdeaf11d9f 100644
--- a/math/asir2000/files/patch-ag
+++ b/math/asir2000/files/patch-ag
@@ -1,24 +1,24 @@
---- parse/glob.c.orig Wed Sep 11 17:57:21 2002
-+++ parse/glob.c Thu Oct 17 11:19:30 2002
+--- parse/glob.c.orig Wed Apr 2 18:43:33 2003
++++ parse/glob.c Fri May 2 15:54:46 2003
@@ -51,6 +51,7 @@
#include "al.h"
#include "parse.h"
#include "ox.h"
+#include "version.h"
- #if PARI
+ #if defined(PARI)
#include "genpari.h"
#endif
-@@ -669,7 +670,12 @@
- printf("Copyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\n");
- printf("Copyright 2000,2001, Risa/Asir committers, http://www.openxm.org/.\n");
+@@ -707,11 +708,8 @@
+ printf("Copyright 2000-2003, Risa/Asir committers, http://www.openxm.org/.\n");
printf("GC 6.1(alpha5) copyright 2001, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n");
+ #if PARI
+-#if 0
- printf("PARI 2.2.4, copyright (C) 2002 The PARI Group.\n");
-+#if PARI
-+ printf("%s.\n",PARI_DEVEL_VERSION);
-+#endif
-+#if LAPACK
-+ printf("%s.\n",LAPACK_VERSION);
-+#endif
+-#endif
+- printf("PARI 2.0.17, copyright 1989-1999, C. Batut, K. Belabas, D. Bernardi,\n");
+- printf(" H. Cohen and M. Olivier.\n");
++ printf("%s.\n",PARIVERSION);
++ printf("copyright (C) 2002 The PARI Group.\n");
+ #endif
}
-
diff --git a/math/asir2000/files/patch-ag.orig b/math/asir2000/files/patch-ag.orig
new file mode 100644
index 000000000000..53825d645738
--- /dev/null
+++ b/math/asir2000/files/patch-ag.orig
@@ -0,0 +1,24 @@
+--- parse/glob.c.orig Wed Sep 11 17:57:21 2002
++++ parse/glob.c Thu Oct 17 11:19:30 2002
+@@ -51,6 +51,7 @@
+ #include "al.h"
+ #include "parse.h"
+ #include "ox.h"
++#include "version.h"
+ #if PARI
+ #include "genpari.h"
+ #endif
+@@ -669,7 +670,12 @@
+ printf("Copyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\n");
+ printf("Copyright 2000,2001, Risa/Asir committers, http://www.openxm.org/.\n");
+ printf("GC 6.1(alpha5) copyright 2001, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n");
+- printf("PARI 2.2.4, copyright (C) 2002 The PARI Group.\n");
++#if PARI
++ printf("%s.\n",PARI_DEVEL_VERSION);
++#endif
++#if LAPACK
++ printf("%s.\n",LAPACK_VERSION);
++#endif
+ }
+
+
diff --git a/math/asir2000/files/patch-ba b/math/asir2000/files/patch-ba
new file mode 100644
index 000000000000..8b5533f535f8
--- /dev/null
+++ b/math/asir2000/files/patch-ba
@@ -0,0 +1,79 @@
+--- Makefile.am.orig Mon Mar 24 20:30:38 2003
++++ Makefile.am Fri May 2 15:33:10 2003
+@@ -9,13 +9,15 @@
+
+ SUBDIRS = asm builtin engine fft include io lib parse ${PLOTDIR}
+
+-asirdir = ${libdir}/asir
++bindir = ${prefix}/bin
++asirlibdir = ${datadir}/asir
++asirdir = ${bindir}
+ asir_PROGRAMS = asir
+ asir_SOURCES = parse/main.c
+ asir_LDADD = libasir.a libasir-gc.a
+ CLEANFILES = ${asir_LDADD} asir-openxm-${VERSION}.tgz
+
+-DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
++DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirlibdir}\"
+ INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
+ -I${top_srcdir}/gc/include \
+ @PARIINC@ @MPIINC@ @X_CFLAGS@
+@@ -76,33 +78,33 @@
+ ${INSTALL_DATA} libasir-gc.a ${DESTDIR}${libdir}/libasir-gc.a
+
+ install-openxm: asir${EXEEXT} install-libasir install-libasir-gc
+- -mkdir -p ${DESTDIR}${bindir}
+- ${INSTALL_PROGRAM} asir ${DESTDIR}${bindir}
+- -mkdir -p ${DESTDIR}${asirdir}
+- (cd ${top_srcdir}/lib; ${MAKE} install-doc install-lib)
+- -rm -f ${DESTDIR}${bindir}/ox_asir${EXEEXT}
+- (cd ${DESTDIR}${bindir} ; ${LN_S} asir${EXEEXT} ox_asir${EXEEXT})
+- -(cd ${DESTDIR}${asirdir}; \
+- rm -f asir${EXEEXT} ox_asir${EXEEXT} ox_launch${EXEEXT} ox_plot${EXEEXT})
+- (cd ${DESTDIR}${asirdir} ; \
+- ${LN_S} ../../bin/asir${EXEEXT} asir${EXEEXT} ; \
+- ${LN_S} asir${EXEEXT} ox_asir${EXEEXT} ; \
+- ${LN_S} asir${EXEEXT} ox_launch${EXEEXT} ; \
+- ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
+- (cd ${top_srcdir}/include; ${MAKE} install)
+- (cd ${top_srcdir}/parse; ${MAKE} install)
++# -mkdir -p ${DESTDIR}${bindir}
++# ${INSTALL_PROGRAM} asir /usr/local/bin
++# -mkdir -p ${DESTDIR}${asirdir}
++# (cd ${top_srcdir}/lib; ${MAKE} install-doc install-lib)
++# -rm -f ${DESTDIR}${bindir}/ox_asir${EXEEXT}
++# (cd ${DESTDIR}${bindir} ; ${LN_S} asir${EXEEXT} ox_asir${EXEEXT})
++# -(cd ${DESTDIR}${asirdir}; \
++# rm -f asir${EXEEXT} ox_asir${EXEEXT} ox_launch${EXEEXT} ox_plot${EXEEXT})
++# (cd ${DESTDIR}${asirdir} ; \
++# ${LN_S} ../../bin/asir${EXEEXT} asir${EXEEXT} ; \
++# ${LN_S} asir${EXEEXT} ox_asir${EXEEXT} ; \
++# ${LN_S} asir${EXEEXT} ox_launch${EXEEXT} ; \
++# ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
++# (cd ${top_srcdir}/include; ${MAKE} install)
++# (cd ${top_srcdir}/parse; ${MAKE} install)
+
+ install-lib:
+- (cd ${top_srcdir}/lib; ${MAKE} install-lib)
+- -(cd ${DESTDIR}${asirdir}; \
+- rm -f ox_asir${EXEEXT} ox_launch${EXEEXT} ox_plot${EXEEXT})
+- (cd ${DESTDIR}${asirdir} ; \
+- ${LN_S} asir${EXEEXT} ox_asir${EXEEXT} ; \
+- ${LN_S} asir${EXEEXT} ox_launch${EXEEXT} ; \
+- ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
+- -mkdir -p ${DESTDIR}${bindir}
+- -rm -f ${DESTDIR}${bindir}/asir${EXEEXT}
+- (cd ${DESTDIR}${bindir} ; ${LN_S} ../lib/asir/asir${EXEEXT} asir${EXEEXT})
++# (cd ${top_srcdir}/lib; ${MAKE} install-lib)
++# -(cd ${DESTDIR}${asirdir}; \
++# rm -f ox_asir${EXEEXT} ox_launch${EXEEXT} ox_plot${EXEEXT})
++# (cd ${DESTDIR}${asirdir} ; \
++# ${LN_S} asir${EXEEXT} ox_asir${EXEEXT} ; \
++# ${LN_S} asir${EXEEXT} ox_launch${EXEEXT} ; \
++# ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
++# -mkdir -p ${DESTDIR}${bindir}
++# -rm -f ${DESTDIR}${bindir}/asir${EXEEXT}
++# (cd ${DESTDIR}${bindir} ; ${LN_S} ../lib/asir/asir${EXEEXT} asir${EXEEXT})
+
+ install-doc:
+ (cd ${top_srcdir}/lib; ${MAKE} install-doc)
diff --git a/math/asir2000/files/patch-bb b/math/asir2000/files/patch-bb
new file mode 100644
index 000000000000..30e8d758d0fb
--- /dev/null
+++ b/math/asir2000/files/patch-bb
@@ -0,0 +1,10 @@
+--- asm/Makefile.am.orig Fri May 2 02:18:28 2003
++++ asm/Makefile.am Fri May 2 02:18:50 2003
+@@ -1,6 +1,6 @@
+ ## $OpenXM: OpenXM_contrib2/asir2000/asm/Makefile.am,v 1.3 2003/03/20 07:34:08 ohara Exp $
+
+-asirdir = ${prefix}/lib/asir
++asirdir = ${prefix}/share/asir
+ DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
+ INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
+ -I${top_srcdir}/gc/include \
diff --git a/math/asir2000/files/patch-bc b/math/asir2000/files/patch-bc
new file mode 100644
index 000000000000..d6e79cf2d353
--- /dev/null
+++ b/math/asir2000/files/patch-bc
@@ -0,0 +1,10 @@
+--- builtin/Makefile.am.orig Fri May 2 02:19:51 2003
++++ builtin/Makefile.am Fri May 2 02:20:08 2003
+@@ -1,6 +1,6 @@
+ ## $OpenXM: OpenXM_contrib2/asir2000/builtin/Makefile.am,v 1.4 2003/03/20 07:34:09 ohara Exp $
+
+-asirdir = ${prefix}/lib/asir
++asirdir = ${prefix}/share/asir
+ DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
+ INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
+ -I${top_srcdir}/gc/include \
diff --git a/math/asir2000/files/patch-bd b/math/asir2000/files/patch-bd
new file mode 100644
index 000000000000..eb5e1e913731
--- /dev/null
+++ b/math/asir2000/files/patch-bd
@@ -0,0 +1,10 @@
+--- engine/Makefile.am.orig Fri May 2 02:20:57 2003
++++ engine/Makefile.am Fri May 2 02:21:10 2003
+@@ -1,6 +1,6 @@
+ ## $OpenXM: OpenXM_contrib2/asir2000/engine/Makefile.am,v 1.3 2003/03/20 07:34:09 ohara Exp $
+
+-asirdir = ${prefix}/lib/asir
++asirdir = ${prefix}/share/asir
+ DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
+ INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
+ -I${top_srcdir}/gc/include \
diff --git a/math/asir2000/files/patch-be b/math/asir2000/files/patch-be
new file mode 100644
index 000000000000..6de80a67cba1
--- /dev/null
+++ b/math/asir2000/files/patch-be
@@ -0,0 +1,10 @@
+--- fft/Makefile.am.orig Fri May 2 02:22:14 2003
++++ fft/Makefile.am Fri May 2 02:22:25 2003
+@@ -1,6 +1,6 @@
+ ## $OpenXM: OpenXM_contrib2/asir2000/fft/Makefile.am,v 1.3 2003/03/20 07:34:10 ohara Exp $
+
+-asirdir = ${prefix}/lib/asir
++asirdir = ${prefix}/share/asir
+ DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
+ INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
+ -I${top_srcdir}/gc/include \
diff --git a/math/asir2000/files/patch-bf b/math/asir2000/files/patch-bf
new file mode 100644
index 000000000000..7e88ba6e3be2
--- /dev/null
+++ b/math/asir2000/files/patch-bf
@@ -0,0 +1,10 @@
+--- io/Makefile.am.orig Fri May 2 02:23:04 2003
++++ io/Makefile.am Fri May 2 02:23:28 2003
+@@ -1,6 +1,6 @@
+ ## $OpenXM: OpenXM_contrib2/asir2000/io/Makefile.am,v 1.3 2003/03/20 07:34:11 ohara Exp $
+
+-asirdir = ${prefix}/lib/asir
++asirdir = ${prefix}/share/asir
+ DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
+ INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
+ -I${top_srcdir}/gc/include \
diff --git a/math/asir2000/files/patch-bg b/math/asir2000/files/patch-bg
new file mode 100644
index 000000000000..8228cdc9f854
--- /dev/null
+++ b/math/asir2000/files/patch-bg
@@ -0,0 +1,11 @@
+--- parse/Makefile.am.orig Fri May 2 02:24:05 2003
++++ parse/Makefile.am Fri May 2 02:24:23 2003
+@@ -3,7 +3,7 @@
+ incdir = ${prefix}/include/asir
+ inc_HEADERS = comp.h cpp.h parse.h w_stdio.h
+
+-asirdir = ${prefix}/lib/asir
++asirdir = ${prefix}/share/asir
+ DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
+ INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
+ -I${top_srcdir}/gc/include \
diff --git a/math/asir2000/files/patch-bh b/math/asir2000/files/patch-bh
new file mode 100644
index 000000000000..fa47c6eb35d3
--- /dev/null
+++ b/math/asir2000/files/patch-bh
@@ -0,0 +1,10 @@
+--- plot/Makefile.am.orig Fri May 2 02:24:53 2003
++++ plot/Makefile.am Fri May 2 02:25:03 2003
+@@ -1,6 +1,6 @@
+ ## $OpenXM: OpenXM_contrib2/asir2000/plot/Makefile.am,v 1.3 2003/03/20 07:34:13 ohara Exp $
+
+-asirdir = ${prefix}/lib/asir
++asirdir = ${prefix}/share/asir
+ DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
+ INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
+ -I${top_srcdir}/gc/include \
diff --git a/math/asir2000/files/patch-bi b/math/asir2000/files/patch-bi
new file mode 100644
index 000000000000..5a3d2dd3ac9c
--- /dev/null
+++ b/math/asir2000/files/patch-bi
@@ -0,0 +1,11 @@
+--- configure.in.orig Fri May 2 02:12:44 2003
++++ configure.in Fri May 2 02:15:11 2003
+@@ -2,7 +2,7 @@
+
+ AC_INIT([LICENSE])
+ AC_PREREQ(2.53)
+-AM_INIT_AUTOMAKE(asir, 20030307)
++AM_INIT_AUTOMAKE(asir, 20030502)
+ AM_MAINTAINER_MODE
+
+ AC_CANONICAL_SYSTEM
diff --git a/math/asir2000/files/patch-bk b/math/asir2000/files/patch-bk
new file mode 100644
index 000000000000..951cebadfb87
--- /dev/null
+++ b/math/asir2000/files/patch-bk
@@ -0,0 +1,10 @@
+--- lib/Makefile.am.orig Fri May 2 02:30:42 2003
++++ lib/Makefile.am Fri May 2 02:30:57 2003
+@@ -1,6 +1,6 @@
+ ## $OpenXM: OpenXM_contrib2/asir2000/lib/Makefile.am,v 1.7 2003/04/20 07:15:35 noro Exp $
+
+-asirdir = ${libdir}/asir
++asirdir = ${datadir}/asir
+ RR = alpi bfct bgk const cyclic defs.h dfff dmul fctrdata fctrtest \
+ fff glib gr ifplot katsura mat nf num primdec primdec_lex \
+ ratint robot solve sp sturm sym xm primdec_mod