aboutsummaryrefslogtreecommitdiff
path: root/math/atlas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/atlas/Makefile')
-rw-r--r--math/atlas/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index c63854e4b599..5625f37aea05 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -35,7 +35,11 @@ USE_GCC=3.4
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
+.if defined(CPUTYPE)
FFLAGS+= -mtune=${CPUTYPE} -pipe -O2 -ffast-math -fomit-frame-pointer
+.else
+FFLAGS+= -pipe -O2 -ffast-math -fomit-frame-pointer
+.endif
.endif
post-patch: