aboutsummaryrefslogtreecommitdiff
path: root/math/bamg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/bamg/Makefile')
-rw-r--r--math/bamg/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/math/bamg/Makefile b/math/bamg/Makefile
index 42b1ebd4277c..bfe50e550054 100644
--- a/math/bamg/Makefile
+++ b/math/bamg/Makefile
@@ -28,7 +28,6 @@ INSTALL_TARGET= install-world
BINS= bamg bamg-g cvmsh2 drawbdmesh
EXDIRS= NACA012 quadloop square test
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.pre-configure:
@@ -41,20 +40,18 @@ post-patch:
post-install:
.for bin in ${BINS}
- @${STRIP_CMD} ${PREFIX}/bin/${bin}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${bin}
.endfor
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.pdf ${DOCSDIR}
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.pdf ${STAGEDIR}${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
.for exdir in ${EXDIRS}
- @${MKDIR} ${EXAMPLESDIR}/${exdir}
- @${INSTALL_DATA} ${WRKSRC}/examples/${exdir}/* ${EXAMPLESDIR}/${exdir}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${exdir}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${exdir}/* ${STAGEDIR}${EXAMPLESDIR}/${exdir}
.endfor
- @${FIND} ${EXAMPLESDIR} \( -name "*.pl" -or -name "*.sh" \) -exec ${CHMOD} a+x {} \;
- @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+ @${FIND} ${STAGEDIR}${EXAMPLESDIR} \( -name "*.pl" -or -name "*.sh" \) -exec ${CHMOD} a+x {} \;
.endif
.include <bsd.port.post.mk>