aboutsummaryrefslogtreecommitdiff
path: root/math/calctool
diff options
context:
space:
mode:
Diffstat (limited to 'math/calctool')
-rw-r--r--math/calctool/Makefile6
-rw-r--r--math/calctool/files/patch-ab8
2 files changed, 7 insertions, 7 deletions
diff --git a/math/calctool/Makefile b/math/calctool/Makefile
index 5a7d86d90516..072c30586723 100644
--- a/math/calctool/Makefile
+++ b/math/calctool/Makefile
@@ -7,7 +7,7 @@
PORTNAME= calctool
PORTVERSION= 2.4.13
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= nsayer
@@ -27,7 +27,7 @@ MAN1= calctool.1
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_X11)
-USE_XLIB= yes
+USE_XORG= x11
BINARIES+= xcalctool
PLIST_SUB+= X11=""
.else
@@ -57,7 +57,7 @@ FPIC= -fpic
post-patch:
@${REINPLACE_CMD} -e "s#%%FPIC%%#${FPIC}#g" \
- -e "s#%%X11BASE%%#${X11BASE}#g" \
+ -e "s#%%LOCALBASE%%#${LOCALBASE}#g" \
-e "s#%%BINARIES%%#${BINARIES}#g" \
-e "s#%%DATADIR%%#${DATADIR}#g" \
${WRKSRC}/Makefile
diff --git a/math/calctool/files/patch-ab b/math/calctool/files/patch-ab
index d7b779985d83..5c8e17fe46e6 100644
--- a/math/calctool/files/patch-ab
+++ b/math/calctool/files/patch-ab
@@ -34,16 +34,16 @@
#
-#X11INCDIR = -I$(OPENWINHOME)/include
-#X11LIBDIR = -L$(OPENWINHOME)/lib
-+X11INCDIR = -I%%X11BASE%%/include
-+X11LIBDIR = -L%%X11BASE%%/lib
++X11INCDIR = -I%%LOCALBASE%%/include
++X11LIBDIR = -L%%LOCALBASE%%/lib
#-------------------------------------------------------------------------
# If you are compiling the XView version, then the following two lines
# should be uncommented.
#
-XVIEWINCDIR = -I$(OPENWINHOME)/include
-XVIEWLIBDIR = -L$(OPENWINHOME)/lib
-+XVIEWINCDIR = -I%%X11BASE%%/include
-+XVIEWLIBDIR = -L%%X11BASE%%/lib
++XVIEWINCDIR = -I%%LOCALBASE%%/include
++XVIEWLIBDIR = -L%%LOCALBASE%%/lib
#
#=========================================================================
#