aboutsummaryrefslogtreecommitdiff
path: root/math/cantor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/cantor/Makefile')
-rw-r--r--math/cantor/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 3e8186c28b5a..1ca81fbe07b9 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -10,9 +10,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 frontend to mathematical software
-LIB_DEPENDS= libspectre.so:${PORTSDIR}/print/libspectre \
- libqalculate.so:${PORTSDIR}/math/libqalculate \
- libanalitza.so:${PORTSDIR}/math/analitza
+LIB_DEPENDS= libspectre.so:print/libspectre \
+ libqalculate.so:math/libqalculate \
+ libanalitza.so:math/analitza
USE_KDE4= kdelibs kdeprefix automoc4
USES= cmake:outsource pkgconfig python:2 tar:xz
@@ -24,27 +24,27 @@ OPTIONS_DEFINE= LUAJIT MAXIMA OCTAVE R SAGE SCILAB
OPTIONS_SUB= yes # R LUAJIT
LUAJIT_DESC= Build LuaJIT backend and install LuaJIT
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
LUAJIT_CMAKE_OFF= -DWITH_LuaJIT:BOOL=FALSE
MAXIMA_DESC= Install Maxima
-MAXIMA_RUN_DEPENDS= maxima:${PORTSDIR}/math/maxima
+MAXIMA_RUN_DEPENDS= maxima:math/maxima
OCTAVE_DESC= Install Octave
-OCTAVE_RUN_DEPENDS= octave:${PORTSDIR}/math/octave
+OCTAVE_RUN_DEPENDS= octave:math/octave
R_DESC= Build R backend and install R
-R_BUILD_DEPENDS= R:${PORTSDIR}/math/R
-R_RUN_DEPENDS= R:${PORTSDIR}/math/R
+R_BUILD_DEPENDS= R:math/R
+R_RUN_DEPENDS= R:math/R
# Required to set CFLAGS for -lgfortran.
R_USES= fortran
R_CMAKE_OFF= -DWITH_R:BOOL=FALSE
SAGE_DESC= Install Sage
-SAGE_RUN_DEPENDS= sage:${PORTSDIR}/math/sage
+SAGE_RUN_DEPENDS= sage:math/sage
SCILAB_DESC= Install Scilab
-SCILAB_RUN_DEPENDS= scilab:${PORTSDIR}/math/scilab
+SCILAB_RUN_DEPENDS= scilab:math/scilab
post-patch:
${REINPLACE_CMD} -e '/FIND_PROGRAM(_GFORTRAN_EXECUTABLE/s,gfortran,${FC},' \