aboutsummaryrefslogtreecommitdiff
path: root/math/ceres-solver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/ceres-solver/Makefile')
-rw-r--r--math/ceres-solver/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index 49af4a64093f..0cc5f196b70f 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -70,17 +70,17 @@ LAPACK_CMAKE_ON= -DBLAS_LIBRARIES:FILEPATH="${BLASLIB}" \
-DLAPACK_LIBRARIES:FILEPATH="${LAPACKLIB}"
LAPACK_CMAKE_BOOL= LAPACK
ATLAS_USES= blaslapack:atlas
-ATLAS_CMAKE_ON= -DBLA_VENDOR:STRING="ATLAS"
+ATLAS_MAKE_ENV= BLA_VENDOR=ATLAS
ATLAS_IMPLIES= LAPACK
GOTOBLAS_DESC= Goto blas implementation
GOTOBLAS_USES= blaslapack:gotoblas
-GOTOBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="Goto"
+GOTOBLAS_MAKE_ENV= BLA_VENDOR=Goto
GOTOBLAS_IMPLIES= LAPACK
NETLIB_USES= blaslapack:netlib
-NETLIB_CMAKE_ON= -DBLA_VENDOR:STRING="Generic"
+NETLIB_MAKE_ENV= BLA_VENDOR=Generic
NETLIB_IMPLIES= LAPACK
OPENBLAS_USES= blaslapack:openblas
-OPENBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="OpenBLAS"
+OPENBLAS_MAKE_ENV= BLA_VENDOR=OpenBLAS
OPENBLAS_IMPLIES= LAPACK
SPARSE_DESC= Sparse linear algebra library