aboutsummaryrefslogtreecommitdiff
path: root/math/cvc3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/cvc3/Makefile')
-rw-r--r--math/cvc3/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/math/cvc3/Makefile b/math/cvc3/Makefile
new file mode 100644
index 000000000000..3428e2113e44
--- /dev/null
+++ b/math/cvc3/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: cvc3
+# Date created: Mar. 24, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvc3
+PORTVERSION= 1.0
+CATEGORIES= math
+MASTER_SITES= http://www.cs.nyu.edu/acsys/cvc3/download/${PORTVERSION}/ \
+ http://www.cs.nctu.edu.tw/~lwhsu/ports/distfiles/
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= An automatic theorem prover for the SMT problem
+
+LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp4
+
+CONFIGURE_ARGS= --enable-dynamic \
+ --with-arith=gmp \
+ --with-build=optimized \
+ --with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
+CXXFLAGS+= -fPIC
+GNU_CONFIGURE= yes
+USE_BISON= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_PERL5= yes
+
+.include <bsd.port.mk>