aboutsummaryrefslogtreecommitdiff
path: root/math/dieharder/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/dieharder/Makefile')
-rw-r--r--math/dieharder/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index e9e9d1dadb30..16d77356537b 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -16,13 +16,20 @@ COMMENT= A random number generator testsuite
LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
-USE_AUTOTOOLS= aclocal:110 autoheader:262 libtool:15
+USE_AUTOTOOLS= aclocal:110 autoheader:262 libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
MAN1= dieharder.1
MAN3= libdieharder.3
+post-patch:
+ @${REINPLACE_CMD} -e "s|./configure|#./configure|g" \
+ ${WRKSRC}/autogen.sh
+
run-autotools:
@(cd ${WRKSRC}; ${SETENV} ${AUTOTOOLS_ENV} ${SH} ./autogen.sh)
+ @${REINPLACE_CMD} -e "/^ltmain=/!s^\$$ac_aux_dir/ltmain.sh^${LIBTOOLFLAGS} ${LTMAIN}^g" \
+ -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>