aboutsummaryrefslogtreecommitdiff
path: root/math/fityk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/fityk/Makefile')
-rw-r--r--math/fityk/Makefile34
1 files changed, 11 insertions, 23 deletions
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 759026f68470..e6adfea8c9aa 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= fityk
-PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTVERSION= 0.7.0
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,41 +16,30 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Free peak fitting software
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost
+LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost \
+ wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_GNOME= gnometarget gtk20
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.6-config
MAN1= fityk.1
+PLIST_FILES= bin/cfityk \
+ bin/fityk \
+ %%DATADIR%%/fityk_tips.txt \
+ %%DATADIR%%/fitykhelp.htb
+PLIST_DIRS= %%DATADIR%%
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500018
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
-.endif
-
-.if ${OSVERSION} < 500035
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CFLAGS+= -fpermissive
-CPPFLAGS+= -I${LOCALBASE}/include/stlport
-LDFLAGS+= -lstlport_gcc
-.endif
-
-.if defined(WITH_WXGTK24)
-LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
-CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.4-config
-.else
-LIB_DEPENDS+= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
-CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.6-config
+.if ${OSVERSION} < 500000
+BROKEN= "does not compile on 4.x"
.endif
post-patch: