aboutsummaryrefslogtreecommitdiff
path: root/math/fityk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/fityk/Makefile')
-rw-r--r--math/fityk/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 643e4112a37a..cec2c439d976 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= fityk
-PORTVERSION= 0.8.8
-PORTREVISION= 1
+PORTVERSION= 0.8.9
CATEGORIES= math
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Free peak fitting software
@@ -25,15 +24,25 @@ WX_CONF_ARGS= absolute
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-xylib
+CONFIGURE_ARGS= --with-xylib --without-doc
USE_LDCONFIG= yes
MAN1= fityk.1
+PORTDOCS= *
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+post-patch:
+ @${REINPLACE_CMD} -e '/HELP_DEF/s|pkgdatadir|docdir|g' \
+ ${WRKSRC}/src/wxgui/Makefile.in
+
post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/fityk.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${DOCSDIR})
+.endif
@-update-mime-database ${PREFIX}/share/mime
.include <bsd.port.mk>