aboutsummaryrefslogtreecommitdiff
path: root/math/fpc-gmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/fpc-gmp/Makefile')
-rw-r--r--math/fpc-gmp/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/math/fpc-gmp/Makefile b/math/fpc-gmp/Makefile
new file mode 100644
index 000000000000..93000b52547b
--- /dev/null
+++ b/math/fpc-gmp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-gmp
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= math lang
+PKGNAMESUFFIX= -gmp
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to gmp library
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= GMP "Install gmp library" on
+
+.include "${MASTERDIR}/Makefile"