aboutsummaryrefslogtreecommitdiff
path: root/math/gap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gap/Makefile')
-rw-r--r--math/gap/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/gap/Makefile b/math/gap/Makefile
index adc7824b4b0c..af79ecc7cb5f 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -17,6 +17,9 @@ LICENSE= GPLv2+
LIB_DEPENDS= libgmp.so:math/gmp
+BROKEN_aarch64= fails to link: undefined reference to SyAllocBags
+BROKEN_powerpc64= fails to package: 2_manifolds_54.scb: No such file or directory
+
USES= gmake shebangfix tar:bzip2
SHEBANG_FILES= configure \
pkg/GAPDoc-*/*/clean \
@@ -42,8 +45,6 @@ GAP_LIBDIR= ${PREFIX}/lib/${GAP_VERSION}
WRKSRC= ${WRKDIR}/${GAP_VERSION}
PLIST_FILES= bin/gap
-BROKEN_aarch64= Fails to link: undefined reference to SyAllocBags
-
post-patch:
@${REINPLACE_CMD} -i '' -e '1s|/usr/bin/sh|/bin/sh|' \
${WRKSRC}/pkg/happrime/make_tarball