aboutsummaryrefslogtreecommitdiff
path: root/math/gnumeric2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gnumeric2/Makefile')
-rw-r--r--math/gnumeric2/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index 6e0b47d731d4..b36c8f1245d7 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
python:${PORTSDIR}/lang/python
LIB_DEPENDS= gnomeprint.9:${PORTSDIR}/print/gnomeprint \
glade.4:${PORTSDIR}/devel/libglade \
- guile.6:${PORTSDIR}/lang/guile \
+ guile.9:${PORTSDIR}/lang/guile \
gnomeole2.0:${PORTSDIR}/devel/libole2 \
gb.0:${PORTSDIR}/lang/gnomebasic
@@ -41,4 +41,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PLIST_SUB= VERSION=${PORTVERSION}
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>