aboutsummaryrefslogtreecommitdiff
path: root/math/gnuplot+/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gnuplot+/Makefile')
-rw-r--r--math/gnuplot+/Makefile27
1 files changed, 6 insertions, 21 deletions
diff --git a/math/gnuplot+/Makefile b/math/gnuplot+/Makefile
index c5fe4b90517c..58508397d246 100644
--- a/math/gnuplot+/Makefile
+++ b/math/gnuplot+/Makefile
@@ -6,28 +6,21 @@
#
PORTNAME= gnuplot371+
-PORTVERSION= 1.1.9
+PORTVERSION= 1.2.0
CATEGORIES= math japanese graphics
-MASTER_SITES= ftp://ftp.ipc.chiba-u.ac.jp/pub/pub.yamaga/gnuplot+/3.7base/ \
+MASTER_SITES= http://www.h2.dion.ne.jp/~yamaga/gnuplot/ \
ftp://ftp.hipecs.hokudai.ac.jp/pub/GNU/jp/pub.yamaga/gnuplot+/3.7base/ \
ftp://ftp.tohoku.ac.jp/mirror/gnuplot+/3.7base/ \
ftp://ftp.win.ne.jp/pub/graphics/gnuplot/gnuplot+/3.7base/ \
ftp://ftp.rc.tutrp.tut.ac.jp/pub/mirror/gnuplot+/3.7base/
-DISTFILES= gnuplot-3.7.1.tar.gz gnuplot3.7.1+1.1.9.patch.tar.gz \
- gnuplot3.7.1+1.1.9.bugfix
+DISTFILES= gnuplot-3.7.1.tar.gz gnuplot3.7.1+${PORTVERSION}.patch.tar.gz
EXTRACT_ONLY= gnuplot-3.7.1.tar.gz
-MAINTAINER= nakaji@tutrp.tut.ac.jp
+MAINTAINER= nakaji@jp.freebsd.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
VFlib2.24:${PORTSDIR}/japanese/vflib
-.if defined(WITH_JP)
-BUILD_DEPENDS= ${LOCALBASE}/lib/libgd.a:${PORTSDIR}/japanese/gd \
- ${LOCALBASE}/lib/libttf.a:${PORTSDIR}/print/freetype
-.else
-LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
BUILD_DEPENDS= ${LOCALBASE}/lib/libttf.a:${PORTSDIR}/print/freetype
-.endif
USE_XLIB= yes
USE_GMAKE= yes
@@ -57,19 +50,11 @@ GP_DOCS= ${WRKSRC}/Copyright.plus \
${WRKSRC}/gp+/plus.ps \
${WRKSRC}/gp+/plus.tex
-pre-fetch:
-.ifndef WITH_JP
- @echo "**********************************************************"
- @echo "If you want handle Japanese TrueType font, define WITH_JP."
- @echo "**********************************************************"
-.endif
-
post-extract:
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/gnuplot3.7.1+1.1.9.patch.tar.gz ${EXTRACT_AFTER_ARGS} -C ${WRKSRC}
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/gnuplot3.7.1+${PORTVERSION}.patch.tar.gz ${EXTRACT_AFTER_ARGS} -C ${WRKSRC}
pre-patch:
- ${PATCH} ${PATCH_ARGS} < ${WRKSRC}/gnuplot3.7+1.1.patch
- ${PATCH} ${PATCH_ARGS} < ${DISTDIR}/gnuplot3.7.1+1.1.9.bugfix
+ ${PATCH} ${PATCH_ARGS} < ${WRKSRC}/gnuplot3.7+1.2.patch
post-patch:
cd ${WRKSRC}; ${TOUCH} aclocal.m4