aboutsummaryrefslogtreecommitdiff
path: root/math/gnuplot
diff options
context:
space:
mode:
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index f3be049b3f1c..f2a8513c649d 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -18,11 +18,11 @@ COMMENT= A command-driven interactive function plotting program
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --without-tutorial --without-linux-vga --without-gd \
- --with-lasergnu
+CONFIGURE_ARGS= --without-tutorial --without-linux-vga --with-lasergnu
-OPTIONS= PNG "Enable PNG support" on \
- PDF "Enable PDF support" on
+OPTIONS= GD "Enable GD support" on \
+ PDF "Enable PDF support" on \
+ PNG "Enable PNG support" on
MAN1= gnuplot.1 lasergnu.1
INFO= gnuplot
@@ -51,11 +51,11 @@ CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11:="@comment "
.endif
-.if defined(WITHOUT_PNG)
-CONFIGURE_ARGS+= --without-png
+.if defined(WITHOUT_GD)
+CONFIGURE_ARGS+= --without-gd
.else
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
-CONFIGURE_ARGS+= --with-png=${LOCALBASE}
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+CONFIGURE_ARGS+= --with-gd=${LOCALBASE}
.endif
.if defined(WITHOUT_PDF)
@@ -65,6 +65,13 @@ LIB_DEPENDS+= pdf.7:${PORTSDIR}/print/pdflib
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
.endif
+.if defined(WITHOUT_PNG)
+CONFIGURE_ARGS+= --without-png
+.else
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+CONFIGURE_ARGS+= --with-png=${LOCALBASE}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|)/@PACKAGE@/@PKG_MAJOR@|)|g' ${WRKSRC}/src/Makefile.in