aboutsummaryrefslogtreecommitdiff
path: root/math/gotoblas
diff options
context:
space:
mode:
Diffstat (limited to 'math/gotoblas')
-rw-r--r--math/gotoblas/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index 124acb52d335..9bb48ecf9238 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -41,12 +41,16 @@ PLIST_FILES= ${GOTOFILES:S|^|lib/|}
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
-.if ${ARCH} == "amd64" || ${ARCH} == "alpha" || ${ARCH} == "sparc64" || ${ARCH} == "ia64"
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "sparc64"
MAKE_FLAGS+= BINARY64=1
.else
MAKE_FLAGS+= BINARY32=1
.endif
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not link: searches for x86-specific optimizations
+.endif
+
.if defined(WITH_INTERFACE64)
MAKE_FLAGS+= INTERFACE64=1
.endif