aboutsummaryrefslogtreecommitdiff
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 0cc5741e3280..b8c488a595b6 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gretl
-PORTVERSION= 1.0.8
+PORTVERSION= 1.0.9
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,17 +16,15 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Gnu Regression, Econometrics and Time-series Library
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-LIB_DEPENDS= lapack.3:${PORTSDIR}/math/lapack \
- gmp.6:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
WANT_GNOME= yes
-USE_GNOME= gtk20 libxml2
+USE_GNOME= gnometarget gtk20 libxml2
USE_AUTOCONF_VER= 253
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake
@@ -45,4 +43,10 @@ CONFIGURE_ARGS+= --without-gnome
PLIST_SUB+= GRETLDATADIR="share"
.endif
+.if defined(WITH_LAPACK)
+LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
+.else
+CONFIGURE_ARGS+= --with-lapack=no
+.endif
+
.include <bsd.port.post.mk>