aboutsummaryrefslogtreecommitdiff
path: root/math/gretl/files/patch-plugin::Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'math/gretl/files/patch-plugin::Makefile.in')
-rw-r--r--math/gretl/files/patch-plugin::Makefile.in29
1 files changed, 12 insertions, 17 deletions
diff --git a/math/gretl/files/patch-plugin::Makefile.in b/math/gretl/files/patch-plugin::Makefile.in
index 32b467be7b5e..633472cd3d4e 100644
--- a/math/gretl/files/patch-plugin::Makefile.in
+++ b/math/gretl/files/patch-plugin::Makefile.in
@@ -1,17 +1,17 @@
---- plugin/Makefile.in.orig Wed Apr 9 08:46:09 2003
-+++ plugin/Makefile.in Mon Apr 14 12:45:07 2003
-@@ -8,6 +8,10 @@
+--- plugin/Makefile.in.orig Tue Apr 22 00:29:01 2003
++++ plugin/Makefile.in Sun May 4 03:14:38 2003
+@@ -7,6 +7,10 @@
+ MAKE = @MAKE@
INSTALL = @INSTALL@
LN = @LN_S@
-
++
+CPPFLAGS = @CPPFLAGS@
+LDFLAGS = @LDFLAGS@
+INTL_LIBS = @LTLIBINTL@
-+
+
have_gtk = @have_gtk@
- GTK_CFLAGS = @GTK_CFLAGS@
- GTK_LIBS = @GTK_LIBS@
-@@ -36,8 +40,8 @@
+ have_gmp = @have_gmp@
+@@ -38,8 +42,8 @@
override CFLAGS += -I.. -DHAVE_CONFIG_H
LIBTOOL = ../libtool
@@ -22,7 +22,7 @@
GRETLINC = -I$(topsrc)/lib/src
GRETLLIB = ../lib/libgretl-1.0.la
-@@ -46,7 +50,7 @@
+@@ -48,7 +52,7 @@
GTK_CFLAGS += -DGTK_DISABLE_DEPRECATED
GRETL_LIBOLE2_CFLAGS := -I$(topsrc)/plugin $(shell pkg-config --cflags glib-2.0)
else
@@ -31,22 +31,17 @@
endif
SRCS = excel_import.c gnumeric_import.c gretl_matrix.c import_common.c \
-@@ -130,15 +134,15 @@
+@@ -129,11 +133,11 @@
.PHONY:
- install: $(PLUGINS) installdirs
+ install: $(GRETLLIB) $(PLUGINS) installdirs
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) \
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) \
$(PLUGINS) $(plugindir)
- install-strip: $(PLUGINS) installdirs
+ install-strip: $(GRETLLIB) $(PLUGINS) installdirs
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) -s \
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) -s \
$(PLUGINS) $(plugindir)
- install-lapack: $(GRETLLIB) $(LAPACK_PLUGINS) installdirs
-- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) \
-+ $(LIBTOOL) --mode=install $(INSTALL_DATA) \
- $(LAPACK_PLUGINS) $(plugindir)
-
installdirs: