aboutsummaryrefslogtreecommitdiff
path: root/math/gretl/files
diff options
context:
space:
mode:
Diffstat (limited to 'math/gretl/files')
-rw-r--r--math/gretl/files/patch-gnome::Makefile.in15
-rw-r--r--math/gretl/files/patch-gui::Makefile.in23
-rw-r--r--math/gretl/files/patch-lib::Makefile.in35
-rw-r--r--math/gretl/files/patch-plugin::Makefile.in30
-rw-r--r--math/gretl/files/patch-share::Makefile.in11
5 files changed, 65 insertions, 49 deletions
diff --git a/math/gretl/files/patch-gnome::Makefile.in b/math/gretl/files/patch-gnome::Makefile.in
new file mode 100644
index 000000000000..0092772cd745
--- /dev/null
+++ b/math/gretl/files/patch-gnome::Makefile.in
@@ -0,0 +1,15 @@
+--- gnome/Makefile.in.orig Sun Aug 25 03:07:17 2002
++++ gnome/Makefile.in Wed Aug 28 03:10:35 2002
+@@ -18,9 +18,9 @@
+ install_help = install-help-1
+ endif
+
+-desktopdir = $(gnome_prefix)/share/applications
+-mimedir = $(gnome_prefix)/share/mime-info
+-gpixmaps = $(gnome_prefix)/share/pixmaps
++desktopdir = $(gnome_prefix)/share/gnome/applications
++mimedir = $(gnome_prefix)/share/gnome/mime-info
++gpixmaps = $(gnome_prefix)/share/gnome/pixmaps
+ ghelpdir = $(gnome_prefix)/share/gnome/help/gretl
+
+ install: install-images install-misc install-help-dirs $(install_help)
diff --git a/math/gretl/files/patch-gui::Makefile.in b/math/gretl/files/patch-gui::Makefile.in
index a1cd1eb60910..c9366e6b0bde 100644
--- a/math/gretl/files/patch-gui::Makefile.in
+++ b/math/gretl/files/patch-gui::Makefile.in
@@ -1,17 +1,6 @@
---- gui/Makefile.in.orig Thu Jul 11 00:20:39 2002
-+++ gui/Makefile.in Sat Jul 27 09:04:18 2002
-@@ -44,8 +44,8 @@
- LIBS = $(GNOME_LIBS) $(GTK_EXTRA_LIBS) ../lib/libgretl.la
- GUI_CFLAGS = $(GNOME_CFLAGS) $(GTK_EXTRA_CFLAGS)
- desktopdir = $(gnome_prefix)/share/gnome/apps/Applications
-- mimedir = $(gnome_prefix)/share/mime-info
-- gpixmaps = $(gnome_prefix)/share/pixmaps
-+ mimedir = $(gnome_prefix)/share/gnome/mime-info
-+ gpixmaps = $(gnome_prefix)/share/gnome/pixmaps
- ghelpdir = $(gnome_prefix)/share/gnome/help/gretl
- query_install_gnome = install-gnome
- else
-@@ -54,7 +54,7 @@
+--- gui/Makefile.in.orig Mon Aug 26 02:32:00 2002
++++ gui/Makefile.in Wed Aug 28 00:40:11 2002
+@@ -57,7 +57,7 @@
endif
ifeq ($(USE_NLS),yes)
datadir = @datadir@
@@ -20,7 +9,7 @@
DEFS = -DLOCALEDIR=\"$(localedir)\"
endif
-@@ -63,7 +63,7 @@
+@@ -66,7 +66,7 @@
# Directories
bindir = $(prefix)/bin
@@ -29,12 +18,12 @@
tooldir = $(topsrc)/tools
libsrc = $(topsrc)/lib/src
clisrc = $(topsrc)/cli
-@@ -94,7 +94,7 @@
+@@ -100,7 +100,7 @@
$(LIBTOOL) $(INSTALL_PROGRAM) -s $(PROG) $(bindir)/$(PROG)
install-data: installdirs
- $(INSTALL_PROGRAM) $(topsrc)/gretl_sh $(bindir)/gretl
+ $(INSTALL_SCRIPT) $(topsrc)/gretl_sh $(bindir)/gretl
- $(INSTALL_DATA) gretl-logo.xpm $(gretldir)
+ $(INSTALL_DATA) ../pixmaps/gretl-logo.xpm $(gretldir)
$(INSTALL_DATA) $(topsrc)/COPYING $(gretldir)
diff --git a/math/gretl/files/patch-lib::Makefile.in b/math/gretl/files/patch-lib::Makefile.in
index 2fa61b8b6174..961520cf09ab 100644
--- a/math/gretl/files/patch-lib::Makefile.in
+++ b/math/gretl/files/patch-lib::Makefile.in
@@ -1,8 +1,8 @@
---- lib/Makefile.in.orig Thu Jul 11 00:20:39 2002
-+++ lib/Makefile.in Sat Jul 27 08:40:14 2002
-@@ -11,8 +11,8 @@
- XML_CFLAGS = @XML_CFLAGS@
+--- lib/Makefile.in.orig Mon Aug 26 02:31:58 2002
++++ lib/Makefile.in Wed Aug 28 00:42:18 2002
+@@ -12,8 +12,8 @@
XML_LIBS = @XML_LIBS@
+ have_gtk = @have_gtk@
-ifeq ($(INSTALL_PROGRAM),)
- INSTALL_PROGRAM = $(INSTALL) -m 755
@@ -11,16 +11,25 @@
endif
ifeq ($(INSTALL_DATA),)
INSTALL_DATA = $(INSTALL) -m 644
-@@ -28,7 +28,7 @@
-
- # General compile options and libs:
- LIBGRETL = libgretl.la
+@@ -26,7 +26,7 @@
+ libdir = $(prefix)/lib
+ includedir = $(prefix)/include/gretl
+ aclocaldir = $(prefix)/share/aclocal
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+
+ INSTALLDIRS = $(libdir) $(includedir) $(aclocaldir)
+
+@@ -40,7 +40,7 @@
+ LIBGRETL = libgretl.la
+ INSTALL_CFG = install-cfg-old
+ endif
-LIBS = -lm -ldl -L/usr/local/lib -lz $(XML_LIBS)
+LIBS = -lm -lz $(XML_LIBS)
#### End of system configuration section. ####
-@@ -65,15 +65,15 @@
+@@ -77,17 +77,17 @@
.PHONY:
install: $(LIBGRETL) install-data
@@ -31,11 +40,13 @@
- $(LIBTOOL) $(INSTALL_PROGRAM) -s $< $(libdir)/$<
+ $(LIBTOOL) $(INSTALL_DATA) -s $< $(libdir)/$<
- install-data: installdirs
+ install-data: installdirs $(INSTALL_CFG)
$(INSTALL_DATA) $(srcdir)/*.h $(includedir)
$(INSTALL_DATA) ../gretl.m4 $(aclocaldir)
+
+ install-cfg-old: ../gretl-config
- $(INSTALL_PROGRAM) ../gretl-config $(bindir)
+ $(INSTALL_SCRIPT) ../gretl-config $(bindir)
- installdirs:
- $(topsrc)/tools/mkinstalldirs $(libdir) $(includedir) $(aclocaldir)
+ install-cfg-new: ../gretl2.pc
+ $(INSTALL_DATA) ../gretl2.pc $(pkgconfigdir)
diff --git a/math/gretl/files/patch-plugin::Makefile.in b/math/gretl/files/patch-plugin::Makefile.in
index 9eac6fca008c..6413e81a5ddf 100644
--- a/math/gretl/files/patch-plugin::Makefile.in
+++ b/math/gretl/files/patch-plugin::Makefile.in
@@ -1,5 +1,5 @@
---- plugin/Makefile.in.orig Thu Jul 11 00:20:39 2002
-+++ plugin/Makefile.in Sat Jul 27 08:43:08 2002
+--- plugin/Makefile.in.orig Mon Aug 26 02:32:01 2002
++++ plugin/Makefile.in Wed Aug 28 00:45:07 2002
@@ -2,6 +2,7 @@
prefix = @prefix@
@@ -8,25 +8,25 @@
CC = @CC@
CFLAGS = @CFLAGS@
MAKE = @MAKE@
-@@ -25,7 +26,7 @@
+@@ -26,7 +27,7 @@
endif
# Installation directory
-share = $(prefix)/share/gretl
+gretldir = $(libdir)/gretl
- LIBTOOL = $(topsrc)/libtool
- COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
-@@ -45,7 +46,7 @@
- query-ms-ole.lo=ms-ole.lo
- vpath %.c libole2
- vpath %.h libole2
-- LIBOLE2_CFLAGS = -I. `glib-config --cflags`
-+ LIBOLE2_CFLAGS = -I. `$(GLIB_CONFIG) --cflags`
- endif
+ override CFLAGS += -I.. -DHAVE_CONFIG_H
+
+@@ -48,7 +49,7 @@
+ PROGRESS_PLUGIN = progress_bar.so
+ GNUMERIC_PLUGIN = gnumeric_import.so
+ EXCEL_PLUGIN = excel_import.so
+- GRETL_LIBOLE2_CFLAGS := -I. $(shell glib-config --cflags)
++ GRETL_LIBOLE2_CFLAGS := -I. $(shell $(GLIB_CONFIG) --cflags)
+ endif
- all: $(PLUGINS)
-@@ -98,15 +99,15 @@
+ PLUGINS = stats_tables.so panel_data.so des_import.so \
+@@ -139,15 +140,15 @@
.PHONY:
install: $(PLUGINS) installdirs
@@ -46,4 +46,4 @@
+ $(topsrc)/tools/mkinstalldirs $(gretldir)/plugins
clean:
- rm -f *.o *.lo $(PLUGINS) core
+ rm -f *.o *.lo *.so core
diff --git a/math/gretl/files/patch-share::Makefile.in b/math/gretl/files/patch-share::Makefile.in
index 8c2a6a5c6645..53377eeebc2c 100644
--- a/math/gretl/files/patch-share::Makefile.in
+++ b/math/gretl/files/patch-share::Makefile.in
@@ -1,10 +1,11 @@
---- share/Makefile.in.orig Thu Mar 28 07:10:47 2002
-+++ share/Makefile.in Wed May 1 06:56:53 2002
-@@ -1,10 +1,11 @@
+--- share/Makefile.in.orig Tue Aug 20 05:22:47 2002
++++ share/Makefile.in Wed Aug 28 00:48:06 2002
+@@ -1,11 +1,12 @@
topsrc = ..
prefix = @prefix@
+libdir = @libdir@
+ have_gtk = @have_gtk@
-gretldir = $(prefix)/share/gretl
+gretldir = $(libdir)/gretl
@@ -12,5 +13,5 @@
-INSTALL_DATA = cp -fp
+INSTALL_DATA = @INSTALL_DATA@
- .PHONY :
-
+ ifeq ($(have_gtk),2.0)
+ ES_GUI_HLP = gretl.hlp.es.utf8