aboutsummaryrefslogtreecommitdiff
path: root/math/gretl/files
diff options
context:
space:
mode:
Diffstat (limited to 'math/gretl/files')
-rw-r--r--math/gretl/files/patch-Makefile.in14
-rw-r--r--math/gretl/files/patch-cli::Makefile.in38
-rw-r--r--math/gretl/files/patch-gnome::Makefile.in41
-rw-r--r--math/gretl/files/patch-gui2::Makefile.in54
-rw-r--r--math/gretl/files/patch-gui2::omf-install::Makefile.in29
-rw-r--r--math/gretl/files/patch-lib::Makefile.in50
-rw-r--r--math/gretl/files/patch-lib::src::gretl_utils.c13
-rw-r--r--math/gretl/files/patch-plugin::Makefile.in47
-rw-r--r--math/gretl/files/patch-plugin::libole2::ms-ole2.h14
-rw-r--r--math/gretl/files/patch-plugin::tramo-x12a.c25
-rw-r--r--math/gretl/files/patch-plugin::workbook.c10
-rw-r--r--math/gretl/files/patch-po::Makefile.in.in11
-rw-r--r--math/gretl/files/patch-share::Makefile.in48
-rw-r--r--math/gretl/files/patch-share::bcih::Makefile.in21
-rw-r--r--math/gretl/files/patch-tools::ltmain.sh23
15 files changed, 0 insertions, 438 deletions
diff --git a/math/gretl/files/patch-Makefile.in b/math/gretl/files/patch-Makefile.in
deleted file mode 100644
index c4dab95e3ebc..000000000000
--- a/math/gretl/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.in.orig Thu Sep 12 00:35:22 2002
-+++ Makefile.in Mon Oct 21 10:02:37 2002
-@@ -22,8 +22,9 @@
- GUIDIR = gui
- endif
-
--INSTALL_PROGRAM = ${INSTALL} -m 755
--INSTALL_DATA = ${INSTALL} -m 644
-+INSTALL_PROGRAM = @INSTALL_PROGRAM@
-+INSTALL_SCRIPT = @INSTALL_SCRIPT@
-+INSTALL_DATA = @INSTALL_DATA@
-
- export
-
diff --git a/math/gretl/files/patch-cli::Makefile.in b/math/gretl/files/patch-cli::Makefile.in
deleted file mode 100644
index b873bef50c5d..000000000000
--- a/math/gretl/files/patch-cli::Makefile.in
+++ /dev/null
@@ -1,38 +0,0 @@
---- cli/Makefile.in.orig Sun Jun 29 04:06:18 2003
-+++ cli/Makefile.in Fri Jul 25 20:49:23 2003
-@@ -9,12 +9,16 @@
- exec_prefix = @exec_prefix@
- bindir = @bindir@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
-
- have_readline = @have_readline@
- READLINE_LIBS = @READLINE_LIBS@
- READLINE_CFLAGS = @READLINE_CFLAGS@
-
-+CPPFLAGS = @CPPFLAGS@
-+LDFLAGS = @LDFLAGS@
-+INTL_LIBS = @LTLIBINTL@
-+
- ifeq ($(CC),)
- CC = gcc
- endif
-@@ -39,7 +43,7 @@
-
- DEFS = -DLOCALEDIR=\"$(localedir)\" -DHAVE_CONFIG_H
-
--override CFLAGS += -I.. -I$(topsrc) -I$(libsrc) $(READLINE_CFLAGS) $(DEFS)
-+override CFLAGS += -I.. -I$(topsrc) -I$(libsrc) $(READLINE_CFLAGS) $(DEFS) $(CPPFLAGS)
-
- CLI = gretlcli
- LIBTOOL = ../libtool
-@@ -49,7 +53,7 @@
- $(CC) -MM -MG -I$(libsrc) $(DEFS) $< >$*.d 2>/dev/null
-
- $(CLI): $(OBJS)
-- ../libtool --mode=link $(CC) -o $@ $^ $(GRETLLIB) $(READLINE_LIBS)
-+ ../libtool --mode=link $(CC) -o $@ $^ $(GRETLLIB) $(READLINE_LIBS) $(INTL_LIBS) $(LDFLAGS)
-
- -include gretlcli.d
-
diff --git a/math/gretl/files/patch-gnome::Makefile.in b/math/gretl/files/patch-gnome::Makefile.in
deleted file mode 100644
index 0daf4dce042b..000000000000
--- a/math/gretl/files/patch-gnome::Makefile.in
+++ /dev/null
@@ -1,41 +0,0 @@
---- gnome/Makefile.in.orig Tue Aug 27 03:11:56 2002
-+++ gnome/Makefile.in Mon Oct 21 08:27:48 2002
-@@ -2,10 +2,10 @@
- docdir = ../doc
-
- INSTALL = @INSTALL@
--gnome_prefix = @gnome_prefix@
-+datadir = @datadir@
- have_gnome = @have_gnome@
-
--sysconfdir = $(gnome_prefix)/etc
-+sysconfdir = @sysconfdir@
-
- GCONFTOOL = @GCONFTOOL@
- GCONF_SCHEMA_CONFIG_SOURCE = @GCONF_SCHEMA_CONFIG_SOURCE@
-@@ -24,11 +24,11 @@
- install_help = install-help-1
- endif
-
--desktopdir = $(gnome_prefix)/share/applications
--mimedir = $(gnome_prefix)/share/mime-info
--gpixmaps = $(gnome_prefix)/share/pixmaps
--ghelpdir = $(gnome_prefix)/share/gnome/help/gretl
--schemadir = $(gnome_prefix)/etc/gconf/schemas
-+desktopdir = $(datadir)/applications
-+mimedir = $(datadir)/mime-info
-+gpixmaps = $(datadir)/pixmaps
-+ghelpdir = $(datadir)/help/gretl
-+schemadir = $(sysconfdir)/gconf/schemas
-
- install: install-images install-misc install-help-dirs $(install_help) $(install_schemas)
-
-@@ -58,7 +58,7 @@
- cat $$f | sed s+fileref=\"figures/[^\"]*+\&.png+g > \
- $(ghelpdir)/C/chapters/`basename $$f` ; done
- $(INSTALL_DATA) $(docdir)/figures/*.png $(ghelpdir)/C/figures
-- make -C $(omfdir) install
-+ $(MAKE) -C $(omfdir) install
-
- install-help-1:
- $(INSTALL_DATA) topic.dat $(ghelpdir)/C
diff --git a/math/gretl/files/patch-gui2::Makefile.in b/math/gretl/files/patch-gui2::Makefile.in
deleted file mode 100644
index 3ef4b9989ad8..000000000000
--- a/math/gretl/files/patch-gui2::Makefile.in
+++ /dev/null
@@ -1,54 +0,0 @@
---- gui2/Makefile.in.orig Wed Apr 9 03:57:15 2003
-+++ gui2/Makefile.in Mon Apr 14 12:35:47 2003
-@@ -4,6 +4,7 @@
- exec_prefix = @exec_prefix@
- bindir = @bindir@
- libdir = @libdir@
-+datadir= @datadir@
- CC = @CC@
- CFLAGS = @CFLAGS@
- MAKE = @MAKE@
-@@ -44,14 +45,13 @@
- LIBS = $(GNOME_LIBS) $(GTK_EXTRA_LIB) ../lib/libgretl-1.0.la
- GUI_CFLAGS = $(GNOME_CFLAGS) $(GTK_EXTRA_CFLAGS)
- query_install_gnome = install-gnome
-- GNOMEDEF = -DGNOME_DISABLE_DEPRECATED -DDATADIR=\"$(gnome_prefix)/share\"
-+ GNOMEDEF = -DGNOME_DISABLE_DEPRECATED -DDATADIR=\"$(datadir)\"
- else
- LIBS = $(GTK_LIBS) $(GTK_EXTRA_LIB) ../lib/libgretl-1.0.la
- GUI_CFLAGS = $(GTK_CFLAGS) $(GTK_EXTRA_CFLAGS)
- endif
- ifeq ($(USE_NLS),yes)
-- datadir = @datadir@
-- localedir = $(datadir)/locale
-+ localedir = $(prefix)/share/locale
- NLSDEF = -DLOCALEDIR=\"$(localedir)\"
- endif
-
-@@ -64,7 +64,7 @@
-
- # Directories
- bindir = $(prefix)/bin
--gretldir = $(prefix)/share/gretl
-+gretldir = $(datadir)/gretl
- tooldir = $(topsrc)/tools
- libsrc = $(topsrc)/lib/src
- clisrc = $(topsrc)/cli
-@@ -102,7 +102,7 @@
- $(CC) $(CFLAGS) $(GTK_CFLAGS) -c $<
-
- $(GTKEXTRA_LITE):
-- make -C gtkextra-lite
-+ $(MAKE) -C gtkextra-lite
-
- -include $(OBJS:.o=.d)
-
-@@ -115,7 +115,7 @@
- $(LIBTOOL) $(INSTALL_PROGRAM) -s $(PROG) $(bindir)/$(PROG)
-
- install-data: installdirs
-- $(INSTALL_PROGRAM) ../gretl_sh $(bindir)/gretl
-+ $(INSTALL_SCRIPT) ../gretl_sh $(bindir)/gretl
- $(INSTALL_DATA) $(topsrc)/pixmaps/gretl-logo.xpm $(gretldir)
- $(INSTALL_DATA) $(topsrc)/COPYING $(gretldir)
-
diff --git a/math/gretl/files/patch-gui2::omf-install::Makefile.in b/math/gretl/files/patch-gui2::omf-install::Makefile.in
deleted file mode 100644
index b72b4211dc60..000000000000
--- a/math/gretl/files/patch-gui2::omf-install::Makefile.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- gui2/omf-install/Makefile.in.orig Wed Apr 9 01:11:18 2003
-+++ gui2/omf-install/Makefile.in Mon Apr 14 17:37:41 2003
-@@ -1,13 +1,14 @@
--topsrc = $top_srcdir@
-+topsrc = @top_srcdir@
- tooldir = $(topsrc)/tools
-
- INSTALL = @INSTALL@
--gnome_prefix = @gnome_prefix@
-+INSTALL_DATA = @INSTALL_DATA@
-+datadir = @datadir@
-
- VPATH = $(topsrc)/gui2/omf-install
-
--docdir = $(gnome_prefix)/share/gnome/help/gretl/C
--omfdir = $(gnome_prefix)/share/omf/gretl
-+docdir = $(datadir)/help/gretl/C
-+omfdir = $(datadir)/omf/gretl
-
- gretl-C.omf: gretl-C.omf.in
- scrollkeeper-preinstall $(docdir)/`awk 'BEGIN {RS = ">" } \
-@@ -16,5 +17,5 @@
-
- install: gretl-C.omf
- $(tooldir)/mkinstalldirs $(omfdir)
-- $(INSTALL) -m 644 $< $(omfdir)
-- scrollkeeper-update -p $(gnome_prefix)/var/scrollkeeper
-+ $(INSTALL_DATA) $< $(omfdir)
-+ scrollkeeper-update -p /var/log/scrollkeeper
diff --git a/math/gretl/files/patch-lib::Makefile.in b/math/gretl/files/patch-lib::Makefile.in
deleted file mode 100644
index 5b4f58fedb19..000000000000
--- a/math/gretl/files/patch-lib::Makefile.in
+++ /dev/null
@@ -1,50 +0,0 @@
---- lib/Makefile.in.orig Sun Jun 29 04:06:20 2003
-+++ lib/Makefile.in Fri Jul 25 20:47:07 2003
-@@ -18,6 +18,11 @@
-
- have_gtk = @have_gtk@
-
-+datadir = @datadir@
-+CPPFLAGS = @CPPFLAGS@ -DDATADIR=\"$(datadir)\"
-+LDFLAGS = @LDFLAGS@
-+INTL_LIBS = @LTLIBINTL@
-+
- ifeq ($(INSTALL_PROGRAM),)
- INSTALL_PROGRAM = $(INSTALL) -m 755
- endif
-@@ -32,7 +37,7 @@
- libdir = $(prefix)/lib
- includedir = $(prefix)/include/gretl
- aclocaldir = $(prefix)/share/aclocal
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
-
- INSTALLDIRS = $(libdir) $(includedir) $(aclocaldir)
-
-@@ -48,7 +53,7 @@
-
- # hard-coded -L/usr/local/lib is a bodge!!
-
--LIBS = $(LAPACK_LIBS) -lm -ldl -L/usr/local/lib -lz $(XML_LIBS) $(GLIB_LIBS) $(GMP_LIBS)
-+LIBS = $(LAPACK_LIBS) -lm -lz $(XML_LIBS) $(GLIB_LIBS) $(GMP_LIBS) $(INTL_LIBS)
-
- #### End of system configuration section. ####
-
-@@ -76,7 +81,7 @@
-
- LIBTOOL = ../libtool
-
--override CFLAGS += -I.. -I$(topsrc) -I$(libsrc) $(XML_CFLAGS) $(GLIB_CFLAGS) $(GMP_CFLAGS) -DHAVE_CONFIG_H
-+override CFLAGS += -I.. -I$(topsrc) -I$(libsrc) $(XML_CFLAGS) $(GLIB_CFLAGS) $(GMP_CFLAGS) -DHAVE_CONFIG_H $(CPPFLAGS)
-
- COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
-
-@@ -86,7 +91,7 @@
-
- $(LIBGRETL): $(LOBJS) $(AUX_LOBJ)
- $(LIBTOOL) --mode=link $(CC) -o $@ $(LOBJS) $(AUX_LOBJ) \
-- -rpath $(prefix)/lib $(LIBS) -version-info 0:9:0
-+ -rpath $(prefix)/lib $(LIBS) -version-info 0:9:0 $(LDFLAGS)
-
- -include $(LOBJS:.lo=.d)
-
diff --git a/math/gretl/files/patch-lib::src::gretl_utils.c b/math/gretl/files/patch-lib::src::gretl_utils.c
deleted file mode 100644
index b05b6e035e38..000000000000
--- a/math/gretl/files/patch-lib::src::gretl_utils.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- lib/src/gretl_utils.c.orig Mon Sep 30 06:13:40 2002
-+++ lib/src/gretl_utils.c Mon Oct 21 08:31:52 2002
-@@ -1373,8 +1373,8 @@
- if (home != NULL) {
- strcpy(ppaths->gretldir, home);
- } else {
-- strcpy(ppaths->gretldir, GRETL_PREFIX);
-- strcat(ppaths->gretldir, "/share/gretl/");
-+ strcpy(ppaths->gretldir, DATADIR);
-+ strcat(ppaths->gretldir, "/gretl/");
- }
- if (gui) {
- sprintf(ppaths->binbase, "%sdb/", ppaths->gretldir);
diff --git a/math/gretl/files/patch-plugin::Makefile.in b/math/gretl/files/patch-plugin::Makefile.in
deleted file mode 100644
index 633472cd3d4e..000000000000
--- a/math/gretl/files/patch-plugin::Makefile.in
+++ /dev/null
@@ -1,47 +0,0 @@
---- plugin/Makefile.in.orig Tue Apr 22 00:29:01 2003
-+++ plugin/Makefile.in Sun May 4 03:14:38 2003
-@@ -7,6 +7,10 @@
- MAKE = @MAKE@
- INSTALL = @INSTALL@
- LN = @LN_S@
-+
-+CPPFLAGS = @CPPFLAGS@
-+LDFLAGS = @LDFLAGS@
-+INTL_LIBS = @LTLIBINTL@
-
- have_gtk = @have_gtk@
- have_gmp = @have_gmp@
-@@ -38,8 +42,8 @@
- override CFLAGS += -I.. -DHAVE_CONFIG_H
-
- LIBTOOL = ../libtool
--COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
--LINK = $(LIBTOOL) --mode=link $(CC) -module -avoid-version -rpath $(plugindir)
-+COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) $(CPPFLAGS)
-+LINK = $(LIBTOOL) --mode=link $(CC) -module -avoid-version -rpath $(plugindir) $(LDFLAGS)
-
- GRETLINC = -I$(topsrc)/lib/src
- GRETLLIB = ../lib/libgretl-1.0.la
-@@ -48,7 +52,7 @@
- GTK_CFLAGS += -DGTK_DISABLE_DEPRECATED
- GRETL_LIBOLE2_CFLAGS := -I$(topsrc)/plugin $(shell pkg-config --cflags glib-2.0)
- else
-- GRETL_LIBOLE2_CFLAGS := -I$(topsrc)/plugin $(shell glib-config --cflags)
-+ GRETL_LIBOLE2_CFLAGS := -I$(topsrc)/plugin $(shell $(GLIB_CONFIG) --cflags)
- endif
-
- SRCS = excel_import.c gnumeric_import.c gretl_matrix.c import_common.c \
-@@ -129,11 +133,11 @@
- .PHONY:
-
- install: $(GRETLLIB) $(PLUGINS) installdirs
-- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) \
-+ $(LIBTOOL) --mode=install $(INSTALL_DATA) \
- $(PLUGINS) $(plugindir)
-
- install-strip: $(GRETLLIB) $(PLUGINS) installdirs
-- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) -s \
-+ $(LIBTOOL) --mode=install $(INSTALL_DATA) -s \
- $(PLUGINS) $(plugindir)
-
- installdirs:
diff --git a/math/gretl/files/patch-plugin::libole2::ms-ole2.h b/math/gretl/files/patch-plugin::libole2::ms-ole2.h
deleted file mode 100644
index dc25fd58bcaf..000000000000
--- a/math/gretl/files/patch-plugin::libole2::ms-ole2.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- plugin/libole2/ms-ole.h.orig Fri Apr 12 03:41:50 2002
-+++ plugin/libole2/ms-ole.h Thu Dec 19 06:28:05 2002
-@@ -13,10 +13,10 @@
-
- /* This should be done in glib */
- /* Allin Cottrell modifications here */
-+# include <sys/types.h>
- #ifndef _WIN32
- # include <fcntl.h> /* for mode_t */
- #else
--# include <sys/types.h>
- # ifdef notdef
- typedef unsigned long mode_t;
- typedef /* signed */ long off_t;
diff --git a/math/gretl/files/patch-plugin::tramo-x12a.c b/math/gretl/files/patch-plugin::tramo-x12a.c
deleted file mode 100644
index 37e567df1576..000000000000
--- a/math/gretl/files/patch-plugin::tramo-x12a.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- plugin/tramo-x12a.c.orig Tue Feb 18 05:20:25 2003
-+++ plugin/tramo-x12a.c Sun May 4 03:27:36 2003
-@@ -187,7 +187,7 @@
- else strcpy(seats, "seats");
- }
-
--static void truncate (char *str, int n)
-+static void truncate_ (char *str, int n)
- {
- int len = strlen(str);
-
-@@ -361,11 +361,11 @@
- /* formulate name of new variable to add */
- strcpy(varname, pdinfo->varname[0]);
- if (opt == TRAMO_SEATS) {
-- truncate(varname, 5);
-+ truncate_(varname, 5);
- strcat(varname, "_");
- strncat(varname, tramo_series_strings[code], 2);
- } else {
-- truncate(varname, 4);
-+ truncate_(varname, 4);
- strcat(varname, "_");
- strcat(varname, x12a_series_strings[code]);
- }
diff --git a/math/gretl/files/patch-plugin::workbook.c b/math/gretl/files/patch-plugin::workbook.c
deleted file mode 100644
index d91482092391..000000000000
--- a/math/gretl/files/patch-plugin::workbook.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- plugin/workbook.c.orig Fri May 31 22:22:42 2002
-+++ plugin/workbook.c Sat Jul 27 08:45:00 2002
-@@ -24,6 +24,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <glib.h>
-+#include <wchar.h>
-
- #ifdef G_OS_WIN32
- # include "../winconfig.h"
diff --git a/math/gretl/files/patch-po::Makefile.in.in b/math/gretl/files/patch-po::Makefile.in.in
deleted file mode 100644
index 53fa2d5ede09..000000000000
--- a/math/gretl/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig Fri May 24 05:03:49 2002
-+++ po/Makefile.in.in Mon Oct 21 08:10:04 2002
-@@ -21,7 +21,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/gettext/po
-
- INSTALL = @INSTALL@
diff --git a/math/gretl/files/patch-share::Makefile.in b/math/gretl/files/patch-share::Makefile.in
deleted file mode 100644
index 7e699a74e148..000000000000
--- a/math/gretl/files/patch-share::Makefile.in
+++ /dev/null
@@ -1,48 +0,0 @@
---- share/Makefile.in.orig Wed Apr 9 06:54:39 2003
-+++ share/Makefile.in Mon Apr 14 16:09:00 2003
-@@ -1,13 +1,14 @@
- topsrc = @top_srcdir@
-
- prefix = @prefix@
-+datadir = @datadir@
- have_gtk = @have_gtk@
-
--gretldir = $(prefix)/share/gretl
-+gretldir = $(datadir)/gretl
- tooldir = $(topsrc)/tools
- sharesrc = $(topsrc)/share
-
--INSTALL_DATA = cp -fp
-+INSTALL_DATA = @INSTALL_DATA@
-
- ifeq ($(have_gtk),2.0)
- ES_GUI_HLP = $(sharesrc)/gretl.hlp.es.utf8
-@@ -26,7 +27,7 @@
-
- install: installdirs install_datafiles install_scripts install_help
- $(INSTALL_DATA) $(sharesrc)/gretl.stamp $(gretldir)/gretl.stamp
-- make -C bcih install
-+ $(MAKE) -C bcih install
-
- install-strip: install
-
-@@ -50,8 +51,8 @@
- $(tooldir)/mkinstalldirs $(gretldir)
- $(INSTALL_DATA) $(sharesrc)/gretl.hlp $(gretldir)/gretl.hlp
- $(INSTALL_DATA) $(sharesrc)/gretlcli.hlp $(gretldir)/gretlcli.hlp
-- $(INSTALL_DATA) $(ES_GUI_HLP) $(gretldir)/gretl.hlp.es
-- $(INSTALL_DATA) $(ES_CLI_HLP) $(gretldir)/gretlcli.hlp.es
-+# $(INSTALL_DATA) $(ES_GUI_HLP) $(gretldir)/gretl.hlp.es
-+# $(INSTALL_DATA) $(ES_CLI_HLP) $(gretldir)/gretlcli.hlp.es
-
- installdirs:
- $(tooldir)/mkinstalldirs $(gretldir) $(gretldir)/data
-@@ -59,7 +60,7 @@
- $(tooldir)/mkinstalldirs $(gretldir)/scripts $(gretldir)/db
-
- $(UTF8_FILES): $(sharesrc)/gretl.hlp.es $(sharesrc)/gretlcli.hlp.es
-- for f in $^ ; do recode l1..utf-8 < $$f > $$f.utf8 ; done
-+# for f in $^ ; do recode l1..utf-8 < $$f > $$f.utf8 ; done
-
- clean:
- make -C bcih clean
diff --git a/math/gretl/files/patch-share::bcih::Makefile.in b/math/gretl/files/patch-share::bcih::Makefile.in
deleted file mode 100644
index bb2fb399e183..000000000000
--- a/math/gretl/files/patch-share::bcih::Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- share/bcih/Makefile.in.orig Sat Apr 26 04:32:37 2003
-+++ share/bcih/Makefile.in Sun May 4 03:16:24 2003
-@@ -4,7 +4,10 @@
- INSTALL_DATA = cp -fp
-
- prefix = @prefix@
--gretldir = $(prefix)/share/gretl
-+datadir = @datadir@
-+gretldir = $(datadir)/gretl
-+INSTALL_DATA = @INSTALL_DATA@
-+
- VPATH = $(topsrc)/share/bcih
-
- bcih.bin: mkbin bcih.dat
-@@ -21,4 +24,4 @@
- rm -f mkbin bcih.bin
-
- distclean: clean
-- rm -f Makefile
-\ No newline at end of file
-+ rm -f Makefile
diff --git a/math/gretl/files/patch-tools::ltmain.sh b/math/gretl/files/patch-tools::ltmain.sh
deleted file mode 100644
index ab2039515415..000000000000
--- a/math/gretl/files/patch-tools::ltmain.sh
+++ /dev/null
@@ -1,23 +0,0 @@
---- tools/ltmain.sh.orig Mon Feb 10 02:23:55 2003
-+++ tools/ltmain.sh Mon Apr 14 12:23:06 2003
-@@ -967,6 +967,7 @@
- ;;
-
- -avoid-version)
-+ build_old_libs=no
- avoid_version=yes
- continue
- ;;
-@@ -4280,10 +4281,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"