aboutsummaryrefslogtreecommitdiff
path: root/math/gri/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gri/Makefile')
-rw-r--r--math/gri/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/math/gri/Makefile b/math/gri/Makefile
index a155df3bf4b0..48fc1fc1586b 100644
--- a/math/gri/Makefile
+++ b/math/gri/Makefile
@@ -6,34 +6,33 @@
#
PORTNAME= gri
-PORTVERSION= 2.4.4
+PORTVERSION= 2.10.1
CATEGORIES= math
-MASTER_SITES= ftp://ftp.phys.ocean.dal.ca/users/kelley/gri/source/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gri
+DISTNAME= gri-${PORTVERSION}-arch-indep
MAINTAINER= bdodson@scms.utmb.edu
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
+WRKSRC= ${WRKDIR}/gri-${PORTVERSION}
GNU_CONFIGURE= YES
-
+MAKE_ENV+= PREFIX=${PREFIX}
ALL_TARGET= gri
MAN1= gri.1
-MANCOMPRESSED= yes
+
+post-extract:
+ ${CP} ${WRKSRC}/doc/gri-manpage.1 ${WRKSRC}/gri.1
post-install:
-.if !defined(${NOPORTDOCS})
- @-mkdir -p ${PREFIX}/share/doc/gri
- @-mkdir -p ${PREFIX}/share/doc/gri/html
- @-mkdir -p ${PREFIX}/share/doc/gri/html/examples
- @-mkdir -p ${PREFIX}/share/doc/gri/html/resources
- @cd ${WRKSRC}/doc && make PREFIX=${PREFIX} html-install
+.if defined(NOPORTDOCS)
+ ${RM} -rf ${PREFIX}/share/gri/doc
.endif
- @cd ${WRKSRC}/doc && \
- make PREFIX=${PREFIX} INSTALL_MAN="${INSTALL_MAN}" man-install
${CHMOD} 555 ${PREFIX}/bin/gri_merge
${CHMOD} 555 ${PREFIX}/bin/gri_unpage
- ${RM} ${PREFIX}/share/gri/license.txt
+ ${INSTALL_MAN} ${WRKSRC}/gri.1 ${PREFIX}/man/man1
+ @-${RM} ${PREFIX}/share/gri/${PORTVERSION}/license.txt
.include <bsd.port.mk>