aboutsummaryrefslogtreecommitdiff
path: root/math/hs-Agda/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/hs-Agda/Makefile')
-rw-r--r--math/hs-Agda/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index a323aeef942a..d86e179601d9 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -2,42 +2,33 @@
# $FreeBSD$
PORTNAME= Agda
-PORTVERSION= 2.3.0.1
-PORTREVISION= 3
+PORTVERSION= 2.3.2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= A dependently typed functional programming language and proof assistant
+COMMENT= Dependently typed functional programming language and proof assistant
CABAL_SETUP= Setup.hs
-USE_CABAL= hashable>=1.2 hashtables haskeline>=0.6.3.2 \
- haskell-src-exts>=1.9.6 mtl QuickCheck>=2.3 syb>=0.1 \
+USE_CABAL= geniplate>=0.6.0.3 hashable>=1.2 hashtables \
+ haskeline>=0.6.3.2 haskell-src-exts>=1.9.6 mtl \
+ QuickCheck>=2.3 parallel syb>=0.1 unordered-containers>=0.2 \
xhtml zlib>=0.4.0.1
USE_ALEX= yes
USE_HAPPY= yes
USE_ICONV= yes
-EXECUTABLE= agda-mode
+EXECUTABLE= agda-mode agda
INSTALL_PORTDATA= (cd ${WRKSRC} && ${INSTALL_DATA} README ${DATADIR}; \
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DATADIR})
-SHOW_PKGMSG= yes
+OPTIONS_DEFINE= EPIC
-OPTIONS_DEFINE= USE_LOCALE EPIC
-
-USE_LOCALE_DESC= Use encoding specified by the locale
EPIC_DESC= Install the Epic compiler
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
-.if ${PORT_OPTIONS:MUSE_LOCALE}
-CONFIGURE_ARGS+= --flags="use-locale"
-.else
-CONFIGURE_ARGS+= --flags="-use-locale"
-.endif
-
.if ${PORT_OPTIONS:MEPIC}
CONFIGURE_ARGS+= --flags="epic"
USE_CABAL+= epic>=0.1.13