aboutsummaryrefslogtreecommitdiff
path: root/math/hs-Agda/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/hs-Agda/Makefile')
-rw-r--r--math/hs-Agda/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index 3214dd20d9c2..4077c6d640bd 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -7,12 +7,12 @@
PORTNAME= Agda
PORTVERSION= 2.3.0.1
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= A dependently typed functional programming language and proof assistant
-
CABAL_SETUP= Setup.hs
USE_CABAL= hashable hashtables haskeline>=0.6.3.2 \
@@ -29,19 +29,20 @@ INSTALL_PORTDATA= (cd ${WRKSRC} && ${INSTALL_DATA} README ${DATADIR}; \
SHOW_PKGMSG= yes
-OPTIONS= USE_LOCALE "Use encoding specified by the locale" off \
- EPIC "Install the Epic compiler" off
+OPTIONS_DEFINE= USE_LOCALE EPIC
+
+USE_LOCALE_DESC= Use encoding specified by the locale
+EPIC_DESC= Install the Epic compiler
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_USE_LOCALE)
+.if ${PORT_OPTIONS:MUSE_LOCALE}
CONFIGURE_ARGS+= --flags="use-locale"
.else
CONFIGURE_ARGS+= --flags="-use-locale"
.endif
-.if defined(WITH_EPIC)
+.if ${PORT_OPTIONS:MEPIC}
CONFIGURE_ARGS+= --flags="epic"
USE_CABAL+= epic>=0.1.13
.else