aboutsummaryrefslogtreecommitdiff
path: root/math/hs-semigroupoids/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/hs-semigroupoids/Makefile')
-rw-r--r--math/hs-semigroupoids/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/math/hs-semigroupoids/Makefile b/math/hs-semigroupoids/Makefile
new file mode 100644
index 000000000000..a6271b6b83c2
--- /dev/null
+++ b/math/hs-semigroupoids/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-semigroupoids
+# Date created: July 16, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= semigroupoids
+PORTVERSION= 1.2.5
+CATEGORIES= math haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell 98 semigroupoids: Category sans id
+
+LICENSE= BSD
+
+USE_CABAL= comonad>=1.1.1 contravariant>=0.1.2 semigroups>=0.7.1 \
+ transformers>=0.2.0
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>