aboutsummaryrefslogtreecommitdiff
path: root/math/kaskade/files
diff options
context:
space:
mode:
Diffstat (limited to 'math/kaskade/files')
-rw-r--r--math/kaskade/files/patch-aa90
-rw-r--r--math/kaskade/files/patch-ab14
-rw-r--r--math/kaskade/files/patch-ba36
-rw-r--r--math/kaskade/files/patch-bb36
-rw-r--r--math/kaskade/files/patch-bc19
-rw-r--r--math/kaskade/files/patch-ca86
6 files changed, 0 insertions, 281 deletions
diff --git a/math/kaskade/files/patch-aa b/math/kaskade/files/patch-aa
deleted file mode 100644
index f7e380b7e147..000000000000
--- a/math/kaskade/files/patch-aa
+++ /dev/null
@@ -1,90 +0,0 @@
---- makefile.orig Wed Sep 25 09:32:22 1996
-+++ makefile Fri Sep 25 15:22:12 1998
-@@ -1,6 +1,6 @@
- PURIFY = #purify
- PURELINK = #purelink
--C++ = $(PURIFY) g++
-+C++ = $(PURIFY) g++ -w -I$(X11BASE)/include
- LD = $(PURELINK) g++
-
- #C++ = $(PURIFY) g++ -w -I/sgisoft/gnu/lib/g++-include # !!! SGI GNU 2.7.1
-@@ -18,25 +18,29 @@
- #FORFLAGS = -O -extend_source # SGI
-
- DEBFLAG = -g
--OPTFLAG = -Wall -O -g
-+#OPTFLAG = -Wall -O -g
-
- LIBS = -lX11 -lm $(F77LIBS)
--#LIBDIR = /usr/X11/lib # PC LINUX, XFree86 3.1.1
-+.if ${PORTOBJFORMAT} == "elf"
-+LIBS+=-Wl,-rpath,$(X11BASE)/lib
-+.endif
-
--F77LIBS = -L/opt/SUNWspro/SC4.0/lib -lF77 -lM77 -lsunmath -lsocket -lnsl # SUN
-+LIBDIR = $(X11BASE)/lib # PC LINUX, XFree86 3.1.1
-+
-+#F77LIBS = -L/opt/SUNWspro/SC4.0/lib -lF77 -lM77 -lsunmath -lsocket -lnsl # SUN
- #F77LIBS = -lftn # SGI
- #F77LIBS = -L/opt/SUNWspro/SC3.0/lib -lF77 -lM77 -lcomplex -lsunmath -lnsl -lsocket # SUN SC3.0
- # F77LIBS = -lxlf -lxlf90 -lxlfutil # IBM
- # F77LIBS = -lfor # DEC Alpha
--# F77LIBS = -lf2c # PC LINUX, XFree86 3.1.1
-+F77LIBS = -lf2c # PC LINUX, XFree86 3.1.1
-
--CFLAGS = -ansi
--CPPFLAGS =
-+#CFLAGS = -ansi
-+CPPFLAGS = $(CFLAGS)
- LDFLAGS = $(DEBFLAG)
-
- # -------------------------------------------------------------------------
-
--TargetDirectory = /temp # used for command 'copy'
-+TargetDirectory = /tmp # used for command 'copy'
-
- default: k6
-
-@@ -77,18 +81,18 @@
- FSources = ma28.f madc28.f
-
- # SUN / SGI:
--ma28.o: ma28.f sysmat.h sysmatml.h sysmatsp.h
-- $(FOR) -c $(FORFLAGS) ma28.f
--madc28.o: madc28.f sysmat.h sysmatml.h sysmatsp.h
-- $(FOR) -c $(FORFLAGS) madc28.f
--
--
--# SUN and PC LINUX:
- #ma28.o: ma28.f sysmat.h sysmatml.h sysmatsp.h
- # $(FOR) -c $(FORFLAGS) ma28.f
- #madc28.o: madc28.f sysmat.h sysmatml.h sysmatsp.h
- # $(FOR) -c $(FORFLAGS) madc28.f
-
-+
-+# SUN and PC LINUX:
-+ma28.o: ma28.f sysmat.h sysmatml.h sysmatsp.h
-+ $(FOR) -c $(FORFLAGS) ma28.f
-+madc28.o: madc28.f sysmat.h sysmatml.h sysmatsp.h
-+ $(FOR) -c $(FORFLAGS) madc28.f
-+
- # IBM:
- #ma28.o: ma28.f sysmat.h sysmatml.h sysmatsp.h
- # $(FOR) -c -qextname $(FORFLAGS) ma28.f
-@@ -224,12 +228,12 @@
- k3: $(k3O)
- $(LD) $(LDFLAGS) -o k3 $(k3O) $(LIBS)
-
--k6: $(k6O)
-- $(LD) $(LDFLAGS) -o k6 $(k6O) $(LIBS)
-+#k6: $(k6O)
-+# $(LD) $(LDFLAGS) -o k6 $(k6O) $(LIBS)
-
- # under PC Linux add "-L$(LIBDIR)"
--#k6: $(k6O)
--# $(LD) $(LDFLAGS) -o k6 $(k6O) $(LIBS) -L$(LIBDIR)
-+k6: $(k6O)
-+ $(LD) $(LDFLAGS) -o k6 $(k6O) $(LIBS) -L$(LIBDIR)
-
-
-
diff --git a/math/kaskade/files/patch-ab b/math/kaskade/files/patch-ab
deleted file mode 100644
index 9b38cecb4002..000000000000
--- a/math/kaskade/files/patch-ab
+++ /dev/null
@@ -1,14 +0,0 @@
-*** psdriv.cc.orig Tue Jul 8 23:53:37 1997
---- psdriv.cc Tue Jul 8 23:53:43 1997
-***************
-*** 155,161 ****
---- 155,163 ----
- fprintf(graph->file, "%%!PS-Adobe-2.0\n"); // was 1.0
- fprintf(graph->file, "%%%%Title: %s\n", graph->fileName);
- fprintf(graph->file, "%%%%Creator: MiniGraphic\n");
-+ #ifndef __FreeBSD__
- fprintf(graph->file, "%%%%For: %s\n", cuserid(0));
-+ #endif
- time(&t);
- fprintf(graph->file, "%%%%CreationDate: %s", ctime(&t));
- fprintf(graph->file, "%%%%Pages: (atend)\n");
diff --git a/math/kaskade/files/patch-ba b/math/kaskade/files/patch-ba
deleted file mode 100644
index 8039916422b7..000000000000
--- a/math/kaskade/files/patch-ba
+++ /dev/null
@@ -1,36 +0,0 @@
-*** int.cc.orig Wed Jul 9 14:06:19 1997
---- int.cc Wed Jul 9 14:32:29 1997
-***************
-*** 188,194 ****
-
- // -- interactive
-
-! // cout << "Enter 'y' for mesh plot: "; cout.flush(); gets(s);
- cout << "Postscript picture of mesh plot: ";
-
- s[0] = 'y';
---- 188,194 ----
-
- // -- interactive
-
-! // cout << "Enter 'y' for mesh plot: "; cout.flush(); fgets(s,256,stdin);
- cout << "Postscript picture of mesh plot: ";
-
- s[0] = 'y';
-***************
-*** 204,210 ****
- delete fePost;
- }
-
-! // cout << "Enter 'y' for solution plot: "; cout.flush(); gets(s);
- cout << "Postscript picture of solution plot: ";
- s[0] = 'y';
- if (strchr(s,'y') || strchr(s,'Y'))
---- 204,210 ----
- delete fePost;
- }
-
-! // cout << "Enter 'y' for solution plot: "; cout.flush(); fgets(s,256,stdin);
- cout << "Postscript picture of solution plot: ";
- s[0] = 'y';
- if (strchr(s,'y') || strchr(s,'Y'))
diff --git a/math/kaskade/files/patch-bb b/math/kaskade/files/patch-bb
deleted file mode 100644
index 8fa9bbaa29ff..000000000000
--- a/math/kaskade/files/patch-bb
+++ /dev/null
@@ -1,36 +0,0 @@
-*** kaskade.cc.orig Wed Jul 9 14:06:44 1997
---- kaskade.cc Wed Jul 9 14:09:41 1997
-***************
-*** 101,107 ****
- if (Continue == True) return noPicture;
- if (!Cmd.isTrue("pause")) { Continue = True; return noPicture; }
-
-! char s[5]; cout << " <CR>"; cout.flush(); gets(s); strToLower(s);
- if (strchr(s,'q') || strchr(s,'e')) { cout << "\nEXIT FORCED\n"; exit(1); }
- if (strchr(s,'c') || strchr(s,'g')) { Continue = True; return noPicture; }
- if (strchr(s,'p') || strchr(s,'P')) { return picture; }
---- 101,107 ----
- if (Continue == True) return noPicture;
- if (!Cmd.isTrue("pause")) { Continue = True; return noPicture; }
-
-! char s[5]; cout << " <CR>"; cout.flush(); fgets(s,256,stdin); strToLower(s);
- if (strchr(s,'q') || strchr(s,'e')) { cout << "\nEXIT FORCED\n"; exit(1); }
- if (strchr(s,'c') || strchr(s,'g')) { Continue = True; return noPicture; }
- if (strchr(s,'p') || strchr(s,'P')) { return picture; }
-***************
-*** 110,116 ****
-
- void PauseAnyWay()
- {
-! char s[5]; cout << " <CR>"; cout.flush(); gets(s); strToLower(s);
- if (strchr(s,'q') || strchr(s,'e')) { cout << "\nExit forced\n"; exit(1); }
- }
- //-------------------------------------------------------------------------
---- 110,116 ----
-
- void PauseAnyWay()
- {
-! char s[5]; cout << " <CR>"; cout.flush(); fgets(s,256,stdin); strToLower(s);
- if (strchr(s,'q') || strchr(s,'e')) { cout << "\nExit forced\n"; exit(1); }
- }
- //-------------------------------------------------------------------------
diff --git a/math/kaskade/files/patch-bc b/math/kaskade/files/patch-bc
deleted file mode 100644
index e82654310c83..000000000000
--- a/math/kaskade/files/patch-bc
+++ /dev/null
@@ -1,19 +0,0 @@
-*** sysmatsp.cc.orig Wed Jul 9 14:07:24 1997
---- sysmatsp.cc Wed Jul 9 14:11:23 1997
-***************
-*** 171,177 ****
- void SparseMatrix:: printMatLabFormat() const
- {
- char s[10];
-! printf ("\n--- print A ? <No> "); gets(s);
- strToLower(s);
- if (!strchr(s,'y')) return;
-
---- 171,177 ----
- void SparseMatrix:: printMatLabFormat() const
- {
- char s[10];
-! printf ("\n--- print A ? <No> "); fgets(s,256,stdin);
- strToLower(s);
- if (!strchr(s,'y')) return;
-
diff --git a/math/kaskade/files/patch-ca b/math/kaskade/files/patch-ca
deleted file mode 100644
index a8b01d6ec5b0..000000000000
--- a/math/kaskade/files/patch-ca
+++ /dev/null
@@ -1,86 +0,0 @@
- This patch is for ZGUI and it's not used because it requires an
- outdated version of Tcl/Tk.
-*** zgui/Makefile.orig Tue Feb 6 04:30:35 1996
---- zgui/Makefile Sat Jul 19 21:58:03 1997
-***************
-*** 1,22 ****
-! OS = SUNOS
- CC = gcc
- FORTRAN = f77
- RANLIB = ranlib
-
-! CFLAGS = -g -O -W -Wall
- FFLAGS = -O -xl
-! FTNLIB = -L/opt/SUNWspro/SC3.0/lib -lF77 -lM77
-! LFLAGS = -g
-
- OBJS = $(OBJDIR)/ParLists.o $(OBJDIR)/FtnParLists.o $(OBJDIR)/tclHash.o
- GUIOBJS = $(OBJDIR)/ParLists.o $(OBJDIR)/TclParLists.o $(OBJDIR)/zgui.o\
- $(OBJDIR)/AppStart.o
-
-! TCLLIB = /zib5/Tk_Tcl/tcl7.4/lib # path for TCL libs, depends on your installation
-! TCLINCLUDE = /zib5/Tk_Tcl/tcl7.4/include # path for TCL include files
-
-! TKLIB = /zib5/Tk_Tcl/tk4.0/lib # path for tk libs, depends on your installation
-! TKINCLUDE = /zib5/Tk_Tcl/tk4.0/include # path for tk include files
-
- LIBDIR = lib-$(OS)
- OBJDIR = obj-$(OS)
---- 1,22 ----
-! OS = FreeBSD
- CC = gcc
- FORTRAN = f77
- RANLIB = ranlib
-
-! CFLAGS = -O -W -I/usr/X11R6/include
- FFLAGS = -O -xl
-! FTNLIB = -lF77
-! LFLAGS = -g -L/usr/X11R6/lib
-
- OBJS = $(OBJDIR)/ParLists.o $(OBJDIR)/FtnParLists.o $(OBJDIR)/tclHash.o
- GUIOBJS = $(OBJDIR)/ParLists.o $(OBJDIR)/TclParLists.o $(OBJDIR)/zgui.o\
- $(OBJDIR)/AppStart.o
-
-! TCLLIB = /usr/local/lib # path for TCL libs, depends on your installation
-! TCLINCLUDE = /usr/local/include # path for TCL include files
-
-! TKLIB = /usr/local/lib # path for tk libs, depends on your installation
-! TKINCLUDE = /usr/local/include # path for tk include files
-
- LIBDIR = lib-$(OS)
- OBJDIR = obj-$(OS)
-***************
-*** 61,76 ****
-
- partest: $(LIBDIR)/zplib.a $(OBJDIR)/partest.o
- $(CC) $(OBJDIR)/partest.o -o partest $(LFLAGS) $(LIBDIR)/zplib.a \
-! -L$(TCLLIB) -ltcl7.4 -lm
-
- ftnpartest: $(LIBDIR)/zplib.a $(OBJDIR)/ftnpartest.o
- $(FORTRAN) $(OBJDIR)/ftnpartest.o -o ftnpartest $(LFLAGS) \
-! $(FTNLIB) $(LIBDIR)/zplib.a -L$(TCLLIB) -ltcl7.4 -lm
-
-
- zgui: $(LIBDIR)/zguilib.a
- $(CC) -o zgui $(LFLAGS) $(LIBDIR)/zguilib.a \
-! -L$(TKLIB) -ltk4.0 -L$(TCLLIB) -ltcl7.4 -lXpm -lm -lX11 -lsocket -lnsl
-
- clean:
- rm -rf $(OBJDIR)/* $(LIBDIR)/* partest ftnpartest
---- 61,76 ----
-
- partest: $(LIBDIR)/zplib.a $(OBJDIR)/partest.o
- $(CC) $(OBJDIR)/partest.o -o partest $(LFLAGS) $(LIBDIR)/zplib.a \
-! -L$(TCLLIB) -ltcl74 -lm
-
- ftnpartest: $(LIBDIR)/zplib.a $(OBJDIR)/ftnpartest.o
- $(FORTRAN) $(OBJDIR)/ftnpartest.o -o ftnpartest $(LFLAGS) \
-! $(FTNLIB) $(LIBDIR)/zplib.a -L$(TCLLIB) -ltcl74 -lm
-
-
- zgui: $(LIBDIR)/zguilib.a
- $(CC) -o zgui $(LFLAGS) $(LIBDIR)/zguilib.a \
-! -L$(TKLIB) -ltk40 -L$(TCLLIB) -ltcl74 -lXpm -lm -lX11
-
- clean:
- rm -rf $(OBJDIR)/* $(LIBDIR)/* partest ftnpartest