aboutsummaryrefslogtreecommitdiff
path: root/math/koctave/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/koctave/Makefile')
-rw-r--r--math/koctave/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/math/koctave/Makefile b/math/koctave/Makefile
new file mode 100644
index 000000000000..b8d589e5fae7
--- /dev/null
+++ b/math/koctave/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: koctave
+# Date created: 01 August 2003
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= koctave3
+PORTVERSION= 0.65
+CATEGORIES= math kde
+MASTER_SITES= http://bubben.homelinux.net/~matti/koctave/
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= KDEGUI for octave
+
+RUN_DEPENDS= octave:${PORTSDIR}/math/octave
+
+USE_BZIP2= yes
+USE_LIBTOOL= yes
+USE_QT_VER= 3
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+=--program-transform-name=koctave3
+
+.include <bsd.port.mk>