aboutsummaryrefslogtreecommitdiff
path: root/math/mpc
diff options
context:
space:
mode:
Diffstat (limited to 'math/mpc')
-rw-r--r--math/mpc/Makefile29
-rw-r--r--math/mpc/distinfo3
-rw-r--r--math/mpc/pkg-descr11
-rw-r--r--math/mpc/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/math/mpc/Makefile b/math/mpc/Makefile
new file mode 100644
index 000000000000..a92e0dac9dc2
--- /dev/null
+++ b/math/mpc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: mpc
+# Date created: 05 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpc
+PORTVERSION= 0.6
+CATEGORIES= math devel
+MASTER_SITES= http://www.multiprecision.org/mpc/download/
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Library of complex numbers with arbitrarily high precision
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
+ mpfr.3:${PORTSDIR}/math/mpfr
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gmp=${LOCALBASE} \
+ --with-mpfr=${LOCALBASE}
+USE_LDCONFIG= yes
+
+INFO= mpc
+
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/math/mpc/distinfo b/math/mpc/distinfo
new file mode 100644
index 000000000000..e3e6bf493d21
--- /dev/null
+++ b/math/mpc/distinfo
@@ -0,0 +1,3 @@
+MD5 (mpc-0.6.tar.gz) = 6056aca24cb9891541a4ee256ab3c66a
+SHA256 (mpc-0.6.tar.gz) = bb9654dea33e54d43b1ec8f83037cf91ca5e0de3499fbd2e5aa533cd375eb009
+SIZE (mpc-0.6.tar.gz) = 551769
diff --git a/math/mpc/pkg-descr b/math/mpc/pkg-descr
new file mode 100644
index 000000000000..55da463817d2
--- /dev/null
+++ b/math/mpc/pkg-descr
@@ -0,0 +1,11 @@
+Mpc is a C library for the arithmetic of complex numbers with
+arbitrarily high precision and correct rounding of the result.
+It is built upon and follows the same principles as Mpfr. The
+library is written by Andreas Enge, Philippe Theveny and Paul
+Zimmermann and is distributed under the Gnu Lesser General Public
+License, either version 2.1 of the license, or (at your option)
+any later version. The Mpc library has been registered in France
+by the Agence pour la Protection des Programmes on 2003-02-05
+under the number IDDN FR 001 060029 000 R P 2003 000 10000.
+
+WWW: http://www.multiprecision.org/
diff --git a/math/mpc/pkg-plist b/math/mpc/pkg-plist
new file mode 100644
index 000000000000..597bf35e1d9d
--- /dev/null
+++ b/math/mpc/pkg-plist
@@ -0,0 +1,5 @@
+include/mpc.h
+lib/libmpc.a
+lib/libmpc.la
+lib/libmpc.so
+lib/libmpc.so.1