aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-econometrics/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-econometrics/Makefile')
-rw-r--r--math/octave-forge-econometrics/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/math/octave-forge-econometrics/Makefile b/math/octave-forge-econometrics/Makefile
index 5793fc612b8c..849b15f0c8c8 100644
--- a/math/octave-forge-econometrics/Makefile
+++ b/math/octave-forge-econometrics/Makefile
@@ -1,21 +1,26 @@
-# New ports collection makefile for: octave-forge-econometrics
-# Date created: 8 September 2008
-# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
-#
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
# $FreeBSD$
-#
PORTNAME= octave-forge-econometrics
-PORTVERSION= 1.0.8
-PORTREVISION= 7
+PORTVERSION= 1.1.0
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-GNU_CONFIGURE= yes
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
RUN_DEPENDS+= ${TARBALLS_DIR}/optim.tar.gz:${PORTSDIR}/math/octave-forge-optim
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
.include <bsd.port.post.mk>