aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-ga
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-ga')
-rw-r--r--math/octave-forge-ga/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/octave-forge-ga/Makefile b/math/octave-forge-ga/Makefile
index 76dd3c36d5c6..446ed430cf48 100644
--- a/math/octave-forge-ga/Makefile
+++ b/math/octave-forge-ga/Makefile
@@ -13,6 +13,10 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
RUN_DEPENDS+= ${TARBALLS_DIR}/communications.tar.gz:${PORTSDIR}/math/octave-forge-communications
.include <bsd.port.pre.mk>
@@ -22,6 +26,6 @@ do-build:
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>