aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-octproj/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-octproj/Makefile')
-rw-r--r--math/octave-forge-octproj/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-octproj/Makefile b/math/octave-forge-octproj/Makefile
index adec6fc45a2b..24b809d6b0d0 100644
--- a/math/octave-forge-octproj/Makefile
+++ b/math/octave-forge-octproj/Makefile
@@ -13,7 +13,11 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
LIB_DEPENDS+= proj:${PORTSDIR}/graphics/proj
@@ -24,6 +28,6 @@ post-patch:
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>